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[bookmark: _Toc508631571][bookmark: _Toc508632684][bookmark: _Toc508632724]Introduction 
[bookmark: _Toc508632640]The objective of this training is to build remote sensing capacity of the participants. We will review image processing theory and fundamental concepts while working through hands on exercises. Specific learning objectives are:
· [bookmark: _Toc508632641]Learning how to make a land cover map
· [bookmark: _Toc508632642]Understanding the principles and good practice guidance for mapping change between two time points and learning how to create a land cover change map.  
· [bookmark: _Toc508632643]Understanding the good practice guidance and conduct an accuracy assessment on both map products.
[bookmark: _Toc508632644]Module 1: Project Planning and Data Acquisition 
[bookmark: _Toc508632645]Project planning and methods documentation play a key role in any remote sensing analysis project.  This module is designed to encourage workshop participants to think through their remote sensing approach to ensure the resulting products will be relevant to their needs and that the chosen methods are well documented and transparent. The user will also learn how to use Google Earth Engine to prepare and download cloud-free Landsat composites for two points in time. These data will then be used to create land cover classifications and in a land cover change mapping workflow.
[bookmark: _Toc508632646]Module 2: Using QGIS for Land Cover Classification and Change Detection
[bookmark: _Toc508632647]The objective of this module is to provide an overview of the land cover classification and land cover change mapping processes. Before delving into these more advanced topics, the user will go through the process of setting up the QGIS environment and will learn how to do basic things in QGIS, like adding layers, adjusting layer symbology, and changing coordinate systems. 
[bookmark: _Toc508632648]Module 3: Accuracy Assessment using Collect Earth Online
[bookmark: _Toc508632649]In this module, the user be introduced to accuracy assessments using Collect Earth Online (CEO) and error matrices. Collect Earth Online is a free, open-source, and user-friendly tool for land monitoring. It is completely web-based and no desktop installation is required. CEO offers simultaneous, cloud-supported data entry by multiple users. It enables crowd-source visual interpretations of satellite imagery, such as Digital Globe and Bing Maps, user-specified WMS and WMTS, and a variety of Earth-observation data sets from Google Earth Engine. In these exercises, the user will calculate measures of user’s accuracy, producer’s accuracy, and overall accuracy (with both raw measures and area estimates) in Excel using error matrices.  

[bookmark: _Toc508631572][bookmark: _Toc508632685][bookmark: _Toc508632725]Data, Software, and Resources
We will be providing the following data and resources to all participants on a USB Flash Drive.
Data:
· Backup – Contains final products that you will be creating. These are backups to be used while longer processes are running. The folder structure mimics the main Data folder structure.
· Images – contains the two Landsat composites (from Google Earth Engine) that will be used in the exercises.
· imagery_subset – you will use this as your working folder in the exercises, and it is empty to start with.
· Models – this folder is empty to start with, but you will place your classification models files in this folder later.
· QGIS_Projects – as you work on exercises, you will save QGIS project files in this folder.
· Shapefiles – this folder contains two shapefiles that you will use for analysis.
· Data_Exploration contains shapefiles that show areas that have changed.
· ROI is empty for now – you will place training data here later on.
OSGEO4W & QGIS
Install for OSGEO4W Shell and QGIS software.
QGIS_Scripts
Custom Python scripts used for processing data in OSGEO4W and QGIS.
PPTs
The PowerPoint presentations from the daily classes.
Supporting_Documentation
Included on the USB are a number of supporting documents including REDD resources (IPCC Guidelines and Tools, 2014) and articles covering concepts and methods used in the manual.


[bookmark: _Toc508631573][bookmark: _Toc508632686][bookmark: _Toc508632726]Course Prerequisites
[bookmark: _Toc508632650]To Prepare
Register for Google Earth Engine Accounts
1. Navigate to the Google Earth Engine registration page by clicking on this link: https://signup.earthengine.google.com/#!/.
2. At the registration page fill in your email, name, affiliation/institution, country/region, and what you would like to accomplish with Earth Engine. For the last blank, fill in something like: “I am participating in a US Forest Service workshop led by GTAC focused on how to use Earth observation data to monitor forest and agricultural landscape changes in throughout Cambodia.”
3. Then agree to the terms and confirm you are not a robot by checking those three boxes. 
4. Click submit.
[bookmark: _Toc508632651]Recommended Skills 
Training participants should be comfortable with GIS concepts and basic data analysis. In addition a general awareness of remote sensing technology would be beneficial.
[bookmark: _Toc508632652]Recommended Internet Browser
Participants should have Google Chrome installed as an internet browser on their workstation– this is the suggested interface to access Google Earth Engine. Download the most recent version here: https://www.google.com/chrome/browser/desktop/index.html.


[bookmark: _Toc508631751][bookmark: _Toc508632653][bookmark: _Toc508632687][bookmark: _Toc508632727][bookmark: _Toc428784171][bookmark: _Toc428784349]Module 1: Project Planning and Data Acquisition 
Project planning and methods documentation play a key role in any remote sensing analysis project.  This module is designed to encourage workshop participants to think through their remote sensing approach to ensure the resulting products will be relevant to their needs and that the chosen methods are well documented and transparent. In this module, the user will also learn how to use Google Earth Engine to prepare and download cloud-free Landsat composites for two points in time. These data will then be used to create land cover classifications and in a land cover change mapping workflow.

[bookmark: _Toc508631574][bookmark: _Toc508632688][bookmark: _Toc508632728]Exercise 1: Remote Sensing Project Planning and Documentation
Project Planning Information
Descriptions and Objectives of the Project (State Issues and Information Needs)
Are you trying to conform to an IPCC Tier?







Descriptions of the end user product (data, information,  monitoring system or map that will be created by the project)
What type of information do you need? A map? An inventory? A change product? (e.g., do you need to know where different land cover types exist or do you just need an inventory of how much there is?)






How will success be defined for this project? Do you require specific accuracy or a certain level of detail in the final map product?




Description of the project area/ extent (national/sub-national/specific forest/etc.) 




Description of the features/classes to be modeled or mapped
Do you have a national definition of forest?
Are you aware of the IPCC guidelines for the recommended land use classes and how they will relate to mapping land cover?
Do you have a key categories that will drive different analysis techniques?





Considerations for measuring, reporting and verifying:
Do you have a strategy; do you know what is required? Do you know where to get the required information? Looking ahead, are you on the right path (who are the decision makers that will inform these strategies?)
What field data will be required for classification and accuracy assessment?
Do you have an existing National Forest Monitoring System (NFMS) in place?





Will you supplement your remote sensing project with existing data (local data on forest type, management intent, records of natural disturbance…)?



Partnerships (vendors, agencies, bureaus, etc.)


Documentation, Archiving and Reporting Worksheet
This worksheet is designed to assist participants with becoming more efficient and informed about documenting and archiving information relating to the planning, preparation, and management of remote sensing datasets and analysis conducted for forest inventory monitoring associated with REDD+ activities. Documentation and archiving remote sensing analysis methods ensures there is transparency and makes it easier to replicate or improve methods as programs increase in complexity and robustness.  For more information on the good practice recommendations for documentation, archiving and reporting please refer to the 2006 IPCC Guidelines Vol. 1 Chp. 6 Section 11.
Analysis Outline
Below we have provided you with headings and some queues on where you should provide information about the workshop processing workflow to ensure transparency about the data and processing steps taken to comply with the good practice recommendations discussed above.  The idea is that the information you provide below should be sufficient and clear enough so that an individual other than you can understand how the analysis was conducted and would be able to replicate it.  Take the time to customize and add additional sections to this document.  This exercise is designed to get you started in this practice and moving down the right path.
Processing Steps:
1. Preparing and Downloading Cloud-free Composite Using Google Earth
Data Used: 

Time frame for composite:

Software Used:

Preprocessing Methods:

Methods for cloud removal:

Assess RS results:

Assumptions: 

Note:  Need to archive outputs before proceeding with analysis. 

2. Creating Band Ratios, Indices and Image Transformations for use in Classification and Change Detection Analysis
Software Used:

Description of Indices:


Assess RS results:



Assumptions: 




Note:  Need to archive outputs before proceeding with analysis.  
3. Image Classification Scheme
Document Clear definitions for classes or categories (i.e., land use categories defined by the IPCC as: Forest Land, Cropland, Grassland, Wetlands, Settlements, and Other Land):





Have you identified any categories as “Key Categories”? How is the analysis different?  Please refer to Volume 1, Chapter 4 of the 2006 IPCC Guidelines on what defines a “Key Category”.

	
Assess RS results:




Document assumptions: 
 






Note:  Need to archive outputs before proceeding with analysis.  
4. Collect Reference Data
What type of reference data are you using?




What is your sampling scheme and what is the logic for its design?




Assess RS results:




Document assumptions: 







Note:  Need to archive outputs before proceeding with analysis.  
5. Perform Land Cover Classification or Land Cover Change Analysis
Software:





Analysis Technique:




Assess RS results:




Assumptions: 






Note:  Need to archive outputs before proceeding to next steps.
6. Perform Accuracy Assessment
Sampling Approach:




Analysis Technique:




Assess results:




Assumptions: 







Note:  Need to archive outputs before proceeding with analysis.  

[bookmark: _Toc497983145][bookmark: _Toc508631575][bookmark: _Toc508632689][bookmark: _Toc508632729]Exercise 2: Preparing Two Dates of Imagery with Google Earth Engine
[bookmark: _Toc508632654]Introduction
In this exercise we will introduce Earth Engine as a means to create these two image data sets to work with. This material is optional, to teach you an alternate way to create a Landsat composite to work with. The benefit of using this method is that you can share these data sets with colleagues to use. You can grant everyone you work with in the office access to work with the same data sets when conducting your change detection projects.
Google Earth Engine (GEE) is a cloud-based platform for massive-scale analysis of geospatial data. GEE allows users access to a petabyte-scale archive of publicly available remotely sensed imagery, ancillary data and computational tools to accomplish a myriad of remote sensing and geospatial tasks at unprecedented speeds and scales. GEE is free for non-commercial use provided users sign up for a GEE account. Since its release in 2010, it has steadily developed toward becoming an established tool for large-scale geospatial analysis. 
In this exercise, you will focus on acquiring and preparing data for the analysis. You will learn how to use GEE for preparing Landsat image data to be used in the land cover change mapping workflow in QGIS. 
Objectives
· Create two cloud-masked images from the two time steps that you would like to map and measure landscape change.
· Export the two Landsat composite data sets to your Earth Engine Drive folder so that you can work with them in QGIS.

1. Introduction to Earth Engine
Sign up for Earth Engine
Note, you should have already signed up. In case you have not yet, follow these instructions to register with Earth Engine.
Navigate to the Google Earth Engine registration page by clicking on this link: https://signup.earthengine.google.com/#!/.  
At the registration page fill in your email, name, affiliation/institution, country/region, and what you would like to accomplish with Earth Engine. For the last blank, fill in something like 
“I am at a workshop with the USFS GTAC, where we are learning how to use Earth Engine to monitor landscape changes in Cambodia.”
Then agree to the terms and confirm you are not a robot by checking those three boxes. 
Click submit.
It may take a couple days or a whole week to get granted an Earth Engine account. 
Open Earth Engine 
In your Google Chrome web browser navigate to Google Earth Engine by clicking this link: https://code.earthengine.google.com/. 
Sign in if prompted.
When/if prompted, allow the EE Code Editor to access your Google Account.
0. Navigate platform features
0. This should take you to the Code Editor interface, which will look similar to the image below.  
[image: ]
0. The bottom panel, highlighted in a dark blue border is where you can display and explore any of your map imagery.
0. The upper left hand panel, highlighted with a red box, has three tabs. The Scripts tab is where all of your scripts are saved, the Docs tab stores the help files and earth engine documentation, and the Assets tab is where you can access all of your loaded data. 
The middle panel, highlighted in a green box, is where you write and run scripts.
The panel in the upper right corner is where user information is printed. There are three tabs here, which include the Inspector, Console, and Tasks. 
The Inspector operates similar to the identify tool in ArcMap, allowing the user to easily get information about layers in the map at specified points (specified by clicking in the Map Panel). 
The Console is used to return messages as the scripts run and print information about the data, intermediate products, and results. It also records any diagnostic messages, such as information about runtime errors.
The Tasks tab is used to manage the exporting of data and results. 
Note: you can click on the Help button in the upper right and select Feature Tour to learn more about each component of the API. 
[image: ]
0. Load a shapefile representing your study region
Earth Engine is a powerful platform for image based analysis. Before we start working with imagery and raster data, we will load a vector file (a shapefile) in order to constrain our study region to an area of interest. 
1. Click on the Assets tab, in the upper left corner of the Earth Engine window. 
[image: ]
1. Then Click on the red NEW button.
1. Select Table Upload from the drop down menu. This is how you will convert a vector file, such as a shapefile formatted data set, into a format we can use in Earth Engine, a Fusion Table. 
Note: Tables, or Fusion Tables, are the vector file format used by Earth Engine.
[image: ]
1. In the new pop up box you will select a vector file from your hard drive. Click Select. Then navigate to a shapefile outlining your study region. We have saved a shapefile of a section of Cambodia that we will work with during the trainings on the USB flash drive. 
3. On your USB flash drive, navigate to the folder path … Data\Shapefiles and select all the Study_Area files. You can select multiple files by holding down the shift key. Then select Open. 
[image: ]
Note: if you have a shapefile outlining a study region you would like to work with instead of the one provided, please feel free to use those files. Make sure to select all the files associated with the vector file of your choice (e.g., .shp, .prj, etc).
3. Keep the default Asset ID Name.
3. Select OK.
1. Open the Tasks tab, located in the upper right corner of the Earth Engine platform. You will notice that a new task has appeared in this window. This indicates that the shapefile is loading into our Earth Engine Assets catalog. The spinning Earth Engine logo signals that the process is still running. To the right, the time the process has been running is displayed. Once the data have loaded, the grey bar of text will change to a blue bar of text and the spinning logo will convert to a check mark.
[image: ]
Return to the Assets tab in the upper left hand corner of the Earth Engine platform. The Study_Area data set should now be available under your list of assets.
 [image: ]
You can adjust the privacy settings of this data table by clicking on the title, Study_Area, under the Assets tab. This opens the properties box. You can choose to adjust the privacy settings: click on Share. 
Here you can add people one by one by entering their email. For each person you add, you can make them either a reader or a writer. 
Alternatively, you can click to make the data readable by anyone: Anyone can read.
(i) Note: in order for colleagues to access your new asset, they also need to have the link that appears in the bottom of the window. 
You can also choose to delete the data from your Earth Engine data library (Assets). Don’t delete the asset yet, you will be working with this file later.
Click on the Import option. Now you will see you have an import called table in your script window. The Asset ID of the table, users/KarisTenneson/Study_Area, is displayed to the right of the variable name, table (note – your own user name will appear after users, not Karis Tenneson).
[image: ]
Rename the variable, table, something that is more descriptive. Click on table to make the cursor active. Type in a new name, such as Study_area.
[image: ]
Display this data in your map window. Type the following lines of code, exactly as they appear below, into the code window:
Map.addLayer(Study_area, null, 'Study area');
Map.centerObject(Study_area, 8);
Then select Run. This will load the vector data set into the map window and zoom into the data set (see image below).
[image: ]
Generate a Time 1 Landsat Composite
0. Load the workshop script repository
2. Next we will work with some pre-made scripts. We will return to this study region file a little later on in the exercise. 
Note: If you would like to learn more about writing your own customized scripts in Earth Engine, there are a number of excellent tutorials available online: https://developers.google.com/earth-engine/tutorials. 
0. Load the script repository (script library) we created for this class to gain access to scripts we will use in this workshop. Click on this link: https://code.earthengine.google.com/?accept_repo=users/KarisTenneson/CambodiaChangeDetection
0. Open the data download script
3. In the scripts tab, expand the Reader section by clicking on it. Note, the numbers in the image may be different than the numbers on your screen, depending on how many script groups you belong to. 
[image: ]
3. In this Reader section, navigate to the scripts folder called users/KarisTenneson/CambodiaChangeDetection. 
3. Open the script called LandsatCompositeDownload.
3. Click Run to see what the script does.
3. Three things happen: 
0. Information has printed to the Console tab, 
[image: ]
0. [bookmark: _GoBack]A new item has appeared in the Tasks tab, 
[image: ]
0. The study region outline and a Landsat composite image have populated the map window. It may take a couple seconds for the imagery to draw. The Landsat composite appearing in the map window includes only tiles that intersect the study region, after they have been clipped to the study region. 
[image: ]
Note: This script masks cloud and cloud shadow pixels. Some areas with persistent cloud cover during the time frame of interest may not have complete cloud free coverage. These areas will have holes in the Landsat composite. You will learn some techniques on how to modify the input parameters in this script to attempt to fill these holes. 
If you would like to better understand some of the processing tools and steps included in the script, there are additional exercises that break down these methods which are available here: https://www.servirglobal.net/Portals/0/Documents/Articles/ChangeDetectionTraining/Module2_Intro_Google_Earth_Engine_Exercise.pdf. 
3. We will next modify this script and learn how to adjust some of the processing parameters.
0. Import the new study region, the shapefile you just loaded, into your Assets folder
Return to the Assets tab. Hover over the name of the shapefile that you just loaded into your assets, e.g., Study_Area.
[image: ]
Three icons appear to the right of the Table name, Study_Area. 
The first is a shortcut to the share settings, 
The second, a pencil, is a shortcut to rename the Table,
The third, an arrow, is a shortcut to import the data table into your current script. Click on the arrow icon. 
Use what you learned when we imported this into an empty script to change the variable name to CambodiaStudyRegion.
0. Change the study region to point to the shapefile you just loaded
Navigate in the script to line 17. This line creates a new variable called studyArea. The variable is a container storing information about a Fusion Table that represents our area of interest. 
Change the information that appears after the equals sign from ee.FeatureCollection('ft:117df8QO7uDtnqdaY-wsUBWaNhCRtuaKwI28Oqx_X')  to CambodiaStudyRegion, the name of Fusion Table you just imported and renamed. See image below.
[image: ]
Click Run and review the impact of the changes on your map data. Do you notice a difference in the map window? You might not, since both study areas are the same – unless you uploaded one of your own shapefiles instead of the one on the USB flashdrive.
0. Specify the season of interest
6. The seasonal settings are located on line 23 and 24. A Julian start date of day 305 represents a start date to look for imagery (the start of the season) as November 1st. A Julian end date of 90 sets the end of the season to March 31st. 
Note: The Julian day number is the integer assigned to everyday in the Julian calendar. January 1 is assigned Julian number 1. You can look up the Julian days of the year using online conversion tables, such as at this website https://landweb.modaps.eosdis.nasa.gov/browse/calendar.html. 
6. Change the seasonal start and end dates to match the season dates in your study region. For example, we can swap the start and end dates to get imagery for both the rainy season and the dry season: 
1. On line 23, change the startJulian to 90 (March 31).
1. On line 24, change the endJulian to 305 (November 1).
[image: ]
6. Click Run. Notice a seasonal difference when you compare to the image on page 8 of this exercise? If you are happy with the seasonal settings, continue to next step. 
2. If you’d like to try a different range of dates, make your changes again on lines 23 and 24. Then click Run and inspect your results. 
6. Save your changes. Click the Save icon. 
[image: ]
3. When asked to make a copy of the script, click Yes.
3. You are then prompted to enter a name or path for the file. You can leave the default settings or you can give the script a unique name that you will remember. When you are satisfied with the file name, click Ok.
3. By default, the script will be saved under users/*YourUsername*/default. You can find this folder by selecting Scripts in the top left and expanding the Owner folder.
0. Specify the year of interest
7. On line 27 change the year to the match the year that you would like to use for one of your change detection end points. For example, try changing it to 2010.
7. Click Run.
7. How does the imagery look?
Other optional settings
7. If there are holes, or gaps in data, over areas with persistent cloud cover you can try modifying the timebuffer variable on line 32. 
3. Increase the timebuffer assignment from 1 to 2 years. This will change your search window and look for images acquired between the two years before and two years after the target year. If the target year is 2014, setting timebuffer to 2 would cause the script to look from images from 2012-2016.
7. Click Run. 
Note: Using a composite built on four years of data may not meet your programmatic needs, such as for REDD+ reporting. You will need to take the program objectives and science standards into account as you design your data composite specification. 
Also, there are cloud parameters that you can adjust before exporting the Landsat composite. This means that some lingering cloud holes may be reduced in size as you progress through the exercise.
7. If you would like, change the year variable on line 32 back to 1 to generate a composite that spans two years of Landsat data acquisitions.
7. Save your changes by clicking the Save icon. 
0. Change the Export File Name 
8. On line 35 you will assign a name to the Landsat composite that you will be exporting to your Drive folder. Change the name to something that indicates the region you are working in, such as CambodiaSubset.
8. You can modify the coordinate reference system on line 38.
The coordinate reference system for the output image is specified using the EPSG code. You can look up the EPSG code for your desired spatial projections at http://spatialreference.org.
0. Choose compositing method
9. On line 43 you can specify either the median or medoid as the compositing method.
Note: a medoid is multidimensional median. It takes into account all bands in the Landsat image and calculates an all band median value. This preserves the relationships between image bands in the final image.
9. On line 47 you can switch between top of atmosphere or surface reflectance values that have been atmospherically corrected.
Adjust cloud and shadow thresholds and compare changes
Starting on line 49 there are a series of parameters you can adjust to redefine your cloud masking thresholds. 
Lowering the cloud threshold, on line 66, will reduce the presence of cloudy and/or hazy pixels in the image. Adjust the cloudThresh variable on line 66 to obtain an optimum level of cloud masking.
You might not be able to eliminate all clouds. Some areas have such persistent cloud cover that there may not be clear imagery within your composite time period.
Then click Run and inspect your results. 
[image: ]
Read through the comments describing the other parameters you can modify. 
For now, leave these set at their default values. However, I encourage you to test out different settings if you have time later.
Save your changes by clicking the Save icon. 
Export to Google Drive
Once you are happy with all the settings, export your data set into your Drive folder. Click Save and Run one more time.
Now navigate to the Tasks tab. Here you will see there is a line with the name of the Landsat composite file you have generated for export, e.g., CambodiaSubset_SR_2013_2015_305_90_Composite. 
The first part of the name matches what you wrote on line 35. 
This is followed by SR or TOA to indicate surface reflectance or top of atmosphere reflectance, respectively. 
Finally the numbers at the end of the name represent the year interval and season interval that you used to search for Landsat images.
[image: ]
Click on the blue RUN button. This will open a new pop up box. Confirm the export parameters and initiate the export. 
Keep all default settings and click the blue RUN button one more time. This will start the export and the blue RUN button under the Tasks tab will change into a spinning Google Earth Engine logo. Once the data is saved into your Drive folder, the spinning logo will be replaced with a check mark and a count of how long it took to export.
[image: ]
Note: After you start the export, you can work on something else. Once you initiate the export, it begins running on the cloud until it completes. It will still run even if you close your window (or turn off your computer). 
Download from Google Drive
Go to https://drive.google.com/drive/my-drive 
Locate your composite, right click, and select download.
[image: ]
If you receive a message reading “Can’t scan file for viruses” click DOWNLOAD ANYWAY. The file will download locally to the location specified in Chrome.
Repeat for Time 2
Generate a time 2 Landsat composite
[bookmark: _6c9v2joclnz6]Use what you have just learned in this exercise to create a second Landsat composite that represents your ‘before’ year. This will be used in the change detection supervised classification process in the next exercise.
Congratulations! You now know how to create and customize mosaics in Google Earth Engine. This script can be adapted to other study areas and time periods that are of interest to you.



[bookmark: _Toc508631752][bookmark: _Toc508632655][bookmark: _Toc508632690][bookmark: _Toc508632730]Module 2: Using QGIS for Land Cover Classification and Change Detection
The objective of this module is to provide an overview of the land cover classification and land cover change mapping processes. Before delving into these more advanced topics, the user will go through the process of setting up the QGIS environment and will learn how to do basic things in QGIS, like adding layers, adjusting layer symbology, and changing coordinate systems.
[bookmark: _Toc437437278][bookmark: _Toc508631576][bookmark: _Toc508632691][bookmark: _Toc508632731]Exercise 3: Introduction to QGIS
[bookmark: _Toc508632656][image: https://www.qgis.org/en/_images/qgis-icon_21.png]
[bookmark: _Toc508632657]Introduction
[bookmark: _Toc508632658]The tools for completing the workflow in this module are all open-source; QGIS is the primary tool used to complete both the land cover map and land cover change map workflow. A QGIS install was created from the OSGeo4W and is included on the website for download. It includes these additional packages:
· [bookmark: _Toc508632659]GDAL
· [bookmark: _Toc508632660]Orfeo ToolBox
· [bookmark: _Toc508632661]QGIS
· [bookmark: _Toc508632662]Python 
[bookmark: _Toc508632663]Objectives
· [bookmark: _Toc508632664]Explore the QGIS Terminal
· [bookmark: _Toc508632665]Create a false color image from the SWIR, NIR, and Red bands from the cloud free Landsat composite image, 
· [bookmark: _Toc508632666]Stack image bands, and 
· [bookmark: _Toc508632667]Do some basic image band arithmetic.  

1. [bookmark: _Toc432084735]Software Install and Data Organization
1. Installing QGIS
0. Transfer the QGIS files in the folder called OSGeo4W64 from the USB flash drive to your c drive (e.g., at C:\OSGeo4W64).
0. Alternatively the files are also available on the SERVIR website, located here: https://s3.amazonaws.com/bucket.servirglobal.net/trainingmaterials/OSGeo4W64.zip  
0. Right click and select to extract the files, save them on the C drive in the following location C:\OSGeo4W64. This is a large file, so the transfer might take around 30 minutes. 
Note: If the path name looks different than C:\OSGeo4W64, your QGIS tools will not work properly.   
1. Download QGIS supplemental scripts and shortcuts
1. Transfer the QGIS_Scripts folder from the USB flash drive to your c drive. The path name should read as C:\QGIS_Scripts
0. Alternatively, download the QGIS_Scripts from https://s3.amazonaws.com/bucket.servirglobal.net/trainingmaterials/QGIS_Scripts.zip. 
0. Save these files on your C drive. The path name should read as C:\QGIS_Scripts.
1. Open the C:\QGIS_Scripts folder and copy the QGIS shortcut and the OSGeo4W command line shell shortcut. You can select both at the same time by holding down the Ctrl key on your keyboard.
1. Paste these shortcuts onto your desktop. If you double click either of these, it will initiate a QGIS session or an OSGeo4 command line session.
Note: There is also the option to set up QGIS with a Virtual Machine (VM) install provided by researchers and instructors at the Boston Education in Earth Observation Data Analysis, Boston University. The files to get this set up are larger than downloading and installing QGIS via the steps above, so you will need access to high speed internet to complete the Virtual Machine setup. The benefit of setting up QGIS on a Virtual Machine is to avoid some of the issues that may be encountered with different operating systems.
Visit the following website to learn how to set up a Virtual Machine and download the necessary files here: https://github.com/beeoda/tutorials/tree/master/1_Introduction  
1. Setting up your file folder structure 
2. Copy the data folder onto your C drive, C:\Data. 
2. You now should have a folder structure C:\Data with subfolders called Images and QGIS_Projects.  You will refer to this directory structure throughout the training, so we recommend that you use this setup as you work through these exercises.
[bookmark: _Toc432084736]Setting up QGIS 
1. Start QGIS 
Start QGIS by clicking on the QGIS shortcut file that you have just copied onto your desktop.
If QGIS doesn’t open, but instead you get an error message about a missing ‘vcruntime140.dll’ file then you will need to copy and paste this file into this location: C:\Windows\System32. 
A copy of the missing vcruntime140.dll file is available in the QGIS_Scripts folder. 
Note: you may need administrative privileges to copy files into the C:\Windows\System32 folder. 
Note: this shortcut will open a version of QGIS with all the plugins, packages, and associated files that you will be using in this online training course. If you would like to learn more about the QGIS download options, information is available online at https://www.qgis.org/en/site/forusers/download.html and http://trac.osgeo.org/osgeo4w/.  
 If the QGIS Tips window opens, close it by clicking OK.
Install the ROI Explorer plugin.
Click on Plugins, then select ‘Manage and Install Plugins…’
Go to the ‘Settings’ tab.
Turn on the box next to ‘Show also experimental plugins’.
Click the ‘Reload repository’ button.
Go to the ‘All’ tab on the upper lefthand corner of the dialogue box.
Search for ROIExplorer.
Select it, then click on ‘Install plugin’.
Close dialogue box.
Your screen should look like the image below – with the ROI Explorer window open on the right hand side of the QGIS interface.
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Setting up the Default Coordinate Reference System
Set the default Coordinate Reference System (CRS) to match the cloud free composite data set for the study area. The case study for this Module is from Cambodia, and has a coordinate reference system of: WGS 84, UTM zone 47N (EPSG: 32647). 
To find the UTM zone and the associated EPSG code for your home country, refer to the Spatial reference website: http://spatialreference.org/ref/epsg/wgs-84-utm-zone-47n/.  
From the menu bar select Settings > Options…. This opens the QGIS Options dialogue. 
On the left side of the Options dialogue select CRS, which stands for coordinate reference system.
In the Default CRS for new projects section click the Select CRS button for the Always start new projects with following CRS field.
[image: ]
This opens the Coordinate Reference System Selector dialogue.
Type 32648 in the Filter field at the top of the dialogue. 
From the Coordinate reference systems of the world section, select WGS 84/UTM zone 48N (see image below).
Click OK to close the CRS dialogue and OK again to close the QGIS dialogue. 
[image: ]
Close QGIS entirely and re-open to allow these changes to take effect. Once reopened the default CRS (shown in lower right of the window, see image below) should be EPSG: 32648.
[image: ]
Note: to learn more about coordinate reference systems in QGIS, visit their online tutorial information: https://docs.qgis.org/2.2/en/docs/user_manual/working_with_projections/working_with_projections.html
Setting up the Toolbars
Add the Advanced Digitizing Toolbar
At the top of the QGIS window, click on View > Toolbars.
Click on Advanced Digitizing Toolbar to add it.
Loading Rasters and Setting Display
Open the 2008-2010 cloud free composite image
Open the provided 2008-2010 cloud free composite tile. This is a tile from Cambodia, just east of Tonle Sap.
From the menu bar select Layer > Add Layer > Add Raster Layer. 
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or click to the left of the Layer pane.
[image: ]
Navigate to C:\Data\Images\ and select the image Cambodia_SR_2008_2010_305_90_Composite.tif.
Note: You will adjust the stretch and color palette later to be able to better see the details in the data. 
[image: ]
Before we adjust the display, first take a few minutes to explore the Map Navigation tools to pan and zoom around the image. QGIS has many different tools for navigating around an image. A few are highlighted in the table on the following page to get you started:
[image: ]


	Button
	Name
	Purpose

	[image: 1.png]
	Zoom in
	Zoom in to a selected area

	[image: 2.png]
	Zoom out
	Zoom out of a selected area

	[image: 3.png]
	Zoom full
	Zoom to the full extent of the highlighted layer

	[image: 4.png]
	Zoom back
	Zoom to the previous extent

	[image: 5.png]
	Edit
	Edit the highlighted vector layer. This can be used to edit attributes or add and delete features.

	[image: 6.png]
	Identify Features
	View the attributes of the highlighted layer at the specified location. This works for either raster or vector layers.

	[image: 7.png]
	Pan Map
	Pan around the map without selecting any layers.

	[image: 8.png]
	Save
	Save the current QGIS project.


Experiment with turning the image on and off by clicking the check box next to the layer name.
[image: ]
[bookmark: _Toc407784740]Setting No Data values
Before adjusting the display of the cloud free composite image, you need to first specify the values used to represent cells with no data. The ‘no data’ value of the images downloaded from the Google Earth Engine script is set to -32768. 
Right click on the composite layer in the layers window and select Properties.
[image: ]
Go to Transparency > No data value > Additional no data value and type in -32768 (note, don’t forget the negative sign). 
Select OK.
Note: now you will notice that the black edges are set to transparent. Next you will adjust the display values so that the display more vividly illustrates the information in the image you are interested in.
Setting the display image
You will set the display of the Landsat composite image to a stretched false color composite using bands 6 (shortwave infrared, SWIR), 4 (near infrared, NIR) and 3 (red). A false color image where the SWIR, NIR, and Red bands are represented as red, green, blue (RGB), respectively. Vegetated areas show up as green and bare soil or impervious surfaces show up as pink with this visualization schema. 
Right click on the Cambodia_SR_2008_2010_305_90_Composite image again, then click on Properties.
In the properties dialog select the Style tab on the left of the dialog box.
 The window will be populated with new options to set. 
Set Band rendering > Render type to Multiband color 
Red band to Band 06 
Green band to Band 04
Blue band to Band 03 
Click on the arrow next to Load min/max values to open up additional settings.
set Accuracy to Estimate 
make sure the box next to Clip extent to canvas is unchecked.
Click the Load button. You’ll notice that the Min/Max values under all the color band options have been updated.
Click Apply in the bottom right of the properties dialog box
[image: ]
Scroll down using the side bar slider on the right and at the bottom of the dialog box the image with these display settings has been loaded in the properties panel.
[image: ]
Then click OK to save the changes.
Note: The false color SWIR, NIR, Red image is now displayed on the map canvas. Vegetated areas appear in shades of green; areas with exposed soils or impervious surfaces appear in shades of pink and red; water as blue. 
[image: ]
If the colors still look a little muted, you can adjust the display settings again. 
This time zoom into a part of region that is fully covered by land.
Now open the style box again (right click on the composite image - Cambodia_SR_2008_2010_305_90_Composite - in the layer pane > Properties > Style). 
Under Load min/max values place a check in the box next to Clip extent to canvas. Note, you may have to re-open the full set of options by clicking the triangle next to the Load Min/max values label.
Select Load. 
Then OK. 
Now your colors should appear more vibrant. See an example image below, yours may look different depending on the area you have zoomed into. If there’s too much contrast, adjust the settings until you have a display you are pleased with.
[image: ]
Save your project
Save your project by clicking on the save icon.
[image: 8.png]
[bookmark: _Toc395863517]Save the project in the QGIS_Projects file folder in the C:\Data\QGIS_Projects directory. Name it Intro_to_QGIS. You’ll notice the default file extension for QGIS projects is ‘.qgs’. 
Load 2013-2015 composite image and adjust display
Repeat steps A to D to load the 2013 cloud free composite. Specify Cambodia_SR_2013_2015_305_90_Composite.tif as the raster to load.
After you have the 2013 image loaded and set the display, toggle between the two dates of imagery by clicking on (and off) the top image layer. Click the box to the left of the layer name in the Layers Panel. 
[image: ] 
Do you see any differences between the images?
Exploring forest cover change and sub-setting data
[bookmark: _Toc407784741]The study region is to the east of Tonle Sap; this region was selected because it has examples of multiple land cover classes, transitions in land cover between the two image dates, and stable areas throughout the image. In the following section, you will do some preliminary data exploration to see which areas within the study region have been documented by a global forest cover change product to have undergone changes in forest cover between 2008 and 2013. 
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Investigate areas of forest change in Google Earth Engine (Hansen’s global forest data products)
Open the Google Earth Engine Code editor by clicking on the link below. 
https://code.earthengine.google.com/
Then navigate to the CambodiaChangeDetection script repository that you loaded during the previous exercise. 
Open the script called HansenForestCoverChangeDisplay. Click Run. 
[image: ]
The script should run when you open the link. Although if it does not, click Run to execute the script. 
The script is very simple – it loads the tree cover, loss and gain image into the window display. Forest appears as green, forest loss as red, and forest gain in blue.
Note: if you’d like to learn more about Hansen’s Forest Data Products and methods, you can find his publication in the Flash Drive under the resources folder. 
You can explore additional Google Earth Engine scripting exercises here https://developers.google.com/earth-engine/tutorial_hansen_01 
Zoom in and scroll around the region – where do you see changes occurring over time? How accurate do you think this data set is for depicting changes within your study region?
Turn the gain layer on and off (see graphic below) – you’ll notice that the same pixel can be classified as loss and gain. Why is this? 
[image: ]
You can also visit the University of Maryland Global Forest Change website, which uses Google Earth Engine to display just the areas of forest loss since 2000. These areas are color coded by the year deforestation occurred. 
Open this link in your web browser: http://earthenginepartners.appspot.com/science-2013-global-forest 
Zoom into the study region, see image below). 
[image: ]
To view the map symbols (city names, roads, etc), you can adjust the transparency of the forest loss layer by sliding the button along the continuum just above the forest loss year legend. 
Where are the most recent, large losses in forest cover located within the study region? This will be the larger blue, red, and orange polygons in the map.
Add forest loss data and zoom to that area
Next you will load a shapefile in QGIS with some previously identified locations that may have undergone changes in land cover between the two study dates. You will investigate these areas so that you can get a sense of what an area undergoing a land cover transition looks like using a false color composite (SWIR, NIR, and red bands). 
Load the shapefile that marks locations that have likely undergone a transition in land cover between the two study dates. From the menu bar select Layer > Add Layer > Add Vector Layer (or click on the Add Vector Layer icon on the left hand panel).
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Click Browse and navigate to the following shapefile: C:\Data\Shapefiles\Data_Exploration\Change_Examples.shp.
Click Open.
In the Layers panel, right click on the newly loaded layer, Change_Examples, and select Properties. Note – you can also just double click on the layer in the layer panel to open the Layer Properties dialog.
Select the Style tag from the left panel.
Click on the Simple fill box. 
Use the dropdown to set the Colors Fill to transparent fill. 
Click the Outline dropdown and set the color to red.
Set the Outline width to 1.
Select OK to close the dialog.
[image: ]
Your Layers panel should now look something like the figure below (you may need to drag layers up or down to replicate the order shown here).
[image: ]
Right click on the Change_Examples layer and select Zoom to Layer.
The features in this shapefile delineate examples of areas that appear to have a change in land cover between the two time steps.
Zoom in closer to one of the change example areas. 
Toggle the 2013-2015 layer on and off to compare differences between the two images.
Note: These areas appear pink in one time period and green in another. This is due to the relative increase in reflectance of the SWIR (displayed red) and relative decrease in NIR reflectance (displayed as green) from the removal of vegetation and exposure of soil.
     [image: ]      [image: ]
             Image from 2008-2010 Composite		     Image from 2013-2015 Composite
(Optional) Explore these areas in Google Earth
If you have Google Earth installed on your laptop, navigate to the kml file stored here: C:\Data\Shapefiles\Data_Exploration
Double-click the file called Change_Examples.kml. 
This will open up the file of these same areas in Google Earth. You can now explore the changes in land cover using the imagery in Google Earth.
Scroll the slider along the timeline of available imagery (in the upper left hand corner of Google Earth) to view older imagery.
[image: ]
The imagery in BING maps is another useful data source to use to explore your study region. BING doesn’t include an option to load shapefiles into the interface, but you can scroll around and zoom in to regions manually. You can access the BING imagery with the imagery date information displayed at this website: https://www.bing.com/maps/aerial. They provide quite clear imagery around the 2008 time period for this study region. 
Creating a subset
When testing new algorithms or forms of analysis, computationally it makes sense to start with an image subset. This makes it faster to repeat the analysis with different parameters or options. You will use the extent of the example shapefile to clip the cloud free composite images. 
Right click on the Change_Examples layer in the layer pane window and select Zoom to Layer. 
With your raster image open in QGIS, go to Raster > Extraction > Clipper.
For the Input file choose your 2008-2010 cloud free composite image.
Save the Output file as C:\Data\Images\imagery_subset\2008_draw_Subset.tif. 
For the Clipping mode choose “Extent”. 
Now draw on the raster layer the extent you want to subset (hint – trace the extent of the display window to get the region of the change example polygons). If you click and drag with the mouse it will automatically draw a bounding box. Notice that the XY values will be updated. Click OK to run the subset.
[image: ]
Leave the clipper dialog open and browse to your 2013-2015 cloud free composite layer and create your subset (remember to change the output name so you don’t overwrite your previous subset) – because the dialog box is still open you can use the same box region that you drew for the 2008-2010 image. Click OK to run, and then Close to close the dialog.
The resulting image subsets load with the blue, green, red bands displayed. Use what you learned earlier in the exercise to change the display to the SWIR, NIR, red false color composite for each subset image. 


Exploring NDVI with a single band gray scale display
Vegetation indices can be calculated from multispectral imagery; these indices enhance features of interest. The normalized difference vegetation index, NDVI, provides a rough estimate of the abundance of healthy vegetation and provides a means of monitoring changes in vegetation over time. It remains the most well-known and oft-used index to detect live green plant canopies.
The NDVI ratio is calculated for each pixel in the image by dividing the difference of the near-infrared (NIR) and red color bands by the sum of the NIR and red color bands. The equation is as follows:


There are three NDVI bands included in the Google Earth Engine cloud-free composite output: the 10th percentile, the median, and the 90th percentile over the composite time range. Including the information about the upper and lower values over time is useful when classifying agricultural land – as these areas often vacillate between high values at the peak of the growing season to low values after harvest. 
NDVI has already been calculated and included in the cloud free composite image stack from the Google Earth Engine script. Bands 7-9 in the cloud free composite are the 10th percentile NDVI value, the median NDVI value, and the 90th percentile NDVI value. You will explore the median value next.
Double click on the 2008_draw_subset in the layers panel. 
Select the Style tab from the left hand column. 
Next use the drop down box to select Singleband gray as the Render type.
Use the drop down box to select Band 08 (this is the median NDVI band) as the Gray band.
Set the Contrast enhancement as Stretch to MinMax.
Keep the other options set as the default value.
Expand the Load min/max values panel and click Load to update these settings. The properties dialog should look similar to the following graphic on the next page, click OK to apply the changes.
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Do the same for 2013 subset data and explore the change in NDVI values in the polygons within the Change_Examples.shp 
Your image should look similar to the graphic on the following page. In this single band gray display, the high NDVI values are white and the low values are black. Your min and max values might be little different than the snapshot above because of different extents drawn during extracting. 
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Exploring NDVI with a single band pseudo color display
Since NDVI represents how green an area is, change the display to a green color scale.
Double click on the 2008_draw_subset in the layers panel. 
Select the Style tab from the left hand column. 
Next use the drop down box to select Singleband pseudocolor as the Render type.
Use the drop down box to select Band 08, the median NDVI band, as the Band (to display).
Specify Greens from the dropdown next to Color (ramp).
Change the Mode to Quantile (or another option of interest to you).
Click the Classify button.
Then Select OK, the properties dialog should look similar to the graphic on the next page.
Do the same for 2013 subset data and explore the change in NDVI values in the polygons within the Change_Examples.shp.
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Now the pixels with high NDVI values will be displayed as a dark green (refer to image below). You can more clearly see areas where there is an abundance of vegetation (green areas) and areas with sparse vegetation (white areas).
[image: ]
Save your project.


[bookmark: _Toc437437279][bookmark: _Toc505765503][bookmark: _Toc508631577][bookmark: _Toc508632692][bookmark: _Toc508632732]Exercise 4: Land Cover Classification
[bookmark: _Toc508632668]Introduction
[bookmark: h.gjdgxs]For this assignment, the requirement is to make a single-date thematic map of some kind using image classification. Learning to do image classification well is extremely important and requires experience. So here is your chance to build some experience. 
[bookmark: _Toc508632669]Objectives
· Create an appropriate list of land cover classes that can be used to create your classification map
· Create regions of interest (ROIs) for your classes that can be used to train a machine learning algorithm
· Classify your image using a Random forests classifier
1. [bookmark: _Toc433024638][bookmark: _Toc505765504][bookmark: _Toc505765535]Project Set up
Open your QGIS project
Start QGIS by clicking on the QGIS shortcut on your desktop  
From the toolbar, go to Project > Open. Navigate to the QGIS project you created in the previous exercise (C:\Data\QGIS_Projects\Intro_to_QGIS.qgs).
Save this as a new project in the same folder (C:\Data\QGIS_Projects\). Name it classification.qgs. 
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Subset images
Since the size of the image you will be working on is not relevant to learning the land cover classification concepts, you will classify a subset of the 2008-2010 cloud free composite image. This will reduce processing time and allow you to redo steps more efficiently. You created a subset in Exercise 3, however you will repeat this step to make sure you are working with the same spatial extent. This time you will subset using a mask layer, a boundary shapefile that has been provided for you in the Data folder.
Subset the 2008-2010 cloud free composite.
Go to Raster > Extraction > Clipper.
Cambodia_SR_2008_2010_305_90_Composite.tif as the input file.
Set the output file as C:\Data\Images\imagery_subset\2008_mask_subset.tif.
Set the Clipping mode to Mask layer.
Set the Mask layer as Processing_Subset (found in C:\Data\ Shapefiles\).
Hit OK to execute.
Close the Clipper dialog box.
Display subset
Use what you learned in Exercise 3 to apply a SWIR, NIR, red (bands 6, 4, 3 in the Landsat cloud free composite image) false color composite stretch to the subset image. You might need to also set no data in this step.
Or if you want to copy the style from the full cloud free composite, right click on the image name (Cambodia_SR_2008_2010_305_90_Composite.tif) under Layers and go to Styles > Copy Style.
[image: ]
To apply this matching stretch to your subset, right click on the 2008_mask_subset image in the Layers panel. Select Styles > Paste Style.
Turn the other cloud free composite images off (click on the box to the left of the layer name in the layers panel).
Zoom to the extent of the new subset layer by right clicking on the 2008_mask_subset layer in the Layer panel and select Zoom to Layer.
[bookmark: _Toc505765505][bookmark: _Toc505765536]Define land cover classes
The first thing you need to do is define the legend for the map, or the list of classes to be included in your map. What classes do you want to map? For this exercise try to keep it simple, but perhaps more interesting than just forest and non-forest. 3 to 5 land cover classes might be a good choice. 
It is also important to have definitions for each of the classes. A lack of clear definitions of the land cover classes can make the resulting maps difficult for others to use. These will probably be working definitions as you move through the land cover classification process. As you become more familiar with the landscape, data limitations, and the ability of the land cover classification methods to discriminate some classes better than others, you will undoubtedly need to update your definitions. 
Defining forest land cover
The following image is an excerpt of text from the Methods and Guidance from the Global Forest Observations Initiative (GFOI) document that describes the Intergovernmental Panel on Climate Change (IPCC) 2003 Good Practice Guidance (GPG) forest definition and suggestions to consider when drafting your forest definition. 
[image: ]
Think about what criteria determine if you have a forest vs. another land cover type? An area of trees that are conserved as a national park, an area that is sustainably logged, and an area managed for palm oil all are characterized by tree cover – but they all have very different land uses. Will their spectral signatures differ? Look at the images below – would you characterize all of the images below as forest?
Note: The snapshots below are from both high resolution aerial images (left hand side) and the Landsat cloud free image composite (right hand side). During this online training course, you will be mapping land cover across the landscape using the Landsat composite, a moderate resolution data set. You may develop definitions based upon your knowledge from the field or from investigating high resolution imagery. However, when deriving your land cover class definitions, it’s also important to be aware of how the definitions relate to the data used to model the land cover. You will continue to explore this relationship throughout the exercise.
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Draft a definition for the forest land cover class. 
Note: the previous series of images are a good illustration of the connections between land use and land cover. You can map land cover with remote sensing data and tools. However most of the time, you are equally, if not more so, interested in land use ̶ for example, reporting the land use, land-use change and forestry activities for REDD+. Below is an excerpt about land use and land cover relationships from the Intergovenmental Panel on Climate Change (IPCC) Working Group II. 
3.3. Land-Use and Land-Cover Change Scenarios 3.3.1. Purpose
The land cover of the Earth has a central role in many important biophysical and socioeconomic processes of global environmental change. Contemporary land cover is changed mostly by human use; therefore, understanding of land use change is essential in understanding land cover change (Turner et al., 1995). Land use is defined through its purpose and is characterized by management practices such as logging, ranching, and cropping. Land cover is the actual manifestation of land use (i.e., forest, grassland, cropland) (IPCC, 2000). Land use change and land cover change (LUC-LCC) involve several processes that are central to the estimation of climate change and its impacts (Turner et al., 1995). Read the full publication here: http://www.ipcc.ch/ipccreports/tar/wg2/index.php?idp=132
Why does land use matter to REDD+ monitoring and reporting activities, and what can you capture with remote sensing tools? 
IPCC greenhouse gas inventory methodologies are used to estimate changes in 5 carbon pools for six categories of land use. The six land use categories include 
1. Forest land
2. Cropland
3. Grassland
4. Wetland
5. Settlements
6. Other land
For more information on these land use definitions and on converting land cover to land use, see here: http://www.ipcc.ch/ipccreports/sres/land_use/index.php?idp=44#s2-2-1
Defining water land cover
Now look at water. Think about what criteria determine if you have water vs. another land cover type? Is your data sensitive to these criteria? 
Are fish ponds in the same class as the ocean along the shoreline? Again, here is an example of similar land cover, but with different land uses – and subsequently different carbon processing rates and characteristics (carbon sources and sinks). Would you classify both images below as water? Will their spectral signatures differ?
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Using these questions and images as a guide, draft a definition for your water land cover class.
Define the other land cover categories you intend to map
Think about the other land cover classes you would like to map. Use what you have learned above and the Landsat data and aerial imagery from Google Earth Engine to draft definitions of your other land cover categories. 
[bookmark: _Toc433024639][bookmark: _Toc505765506][bookmark: _Toc505765537]Creating Regions of Interest for the 2008 image classification
Any supervised classification method requires prior identification of training samples, also referred to as regions of interest (ROI). High quality training data is necessary to get good land cover map results. In the most ideal situation, training data is collected in the field by visiting each of the land cover types to be mapped and collecting attributes. When field collection is not an option, the second best choice is to digitize training data from high resolution imagery, or at the very least from the imagery to be classified. 
In this assignment, you will define regions of interest (ROIs) through a combination of high resolution imagery from online sources and the Landsat cloud free composite. These will be used to train the classifier in a supervised classification using the Orfeo tool and random forests algorithms. The goal of training the classifier is to provide examples of the variety of spectral signatures associated with each class in the map. This can be done in the form of training polygons, which are digitized on an image as Regions of Interest (ROIs). It is important to take time when collecting your training data. This is very important! 
Create your regions of interest shapefile
To collect ROIs in QGIS you need to create a shapefile with features corresponding to your different ROIs. Go to Layer > Create Layer > New Shapefile Layer. 
Under Type, click Polygon. 
Specify the same coordinate reference system as the image you intend to classify – EPSG: 32648 – WGS 84/UTM zone 48N. 
Now add an attribute to your Polygon with the 
Name: Class
Type: Text data 
Click the Add to fields list button
[image: ]
Your box should look like the image above.  
Click OK to create the shapefile. 
It will prompt you to save the ROI. Save it as C:\Data\Shapefiles\ROI\ROI_1.shp.
Digitize your regions of interest
When you draw your ROIs in the next step you will need to represent them as integer values. If you have 5 classes, then your classes will be labeled 1-5. 
In the table below, fill in the corresponding number for each class. Make sure you add in any additional land cover categories you have decided to map. This table will help you keep track of which number corresponds to which class label. 
	Land Cover Class
	Numeric Value

	Forest
	1

	Water
	2

	Fallow/Other
	3

	Ag
	4


Start drawing your ROIs by right clicking the newly created shapefile in the Layers panel > Toggle Editing.
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Click the Add Feature button.
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Left click in the image to draw a polygon, and right click to complete the polygon. 
When you finish drawing an ROI, it will ask you to fill in a value for ‘id’ and ‘Class’. Enter the numeric value (id) and Land Cover Class (Class) from the table on the previous page that correspond to the polygon you’ve just drawn. Revisit the classification scheme in the table you populated a moment ago to keep track of which number corresponds to each land cover class.
Below is an example of an ROI for a water class.
After you enter the number for the class, click OK. 
[image: ]
Note: To create the ROIs today, you can also refer to the imagery data sets available in Google Earth.. Make sure you are looking at imagery collected around the 2008 to 2010 time period.
Forest –Make sure that you create forest regions of interest that represent both areas if you have included both in your land cover classification definition.  
Repeat this multiple times for each land cover class. 
When collecting ROIs, pay attention to the tips in the notes below.
When you are done creating ROIs, right click on your shapefile in the Layers panel and click Toggle Editing to stop editing. 
Save your edits.
Note: You can have more than one polygon that represents the same class. In fact, you should typically have many polygons for each class. Many small ROIs are better than a few large ones (a few hundred pixels tops for each ROI). This can help account for the spectral variations in each land cover class. If you provide just one example of forest, it will be hard to recognize the variety of spectral signatures associated with that class. If you have multiple sub-classes under the same class (such as different tree species all being considered forest), your ROIs should reflect the full breadth of possible spectral signatures. 
You will find that you will need to adjust your training data a number of times (maybe many times!) in order to produce a quality classification. The actual classification part is just pressing a button, what most influences the accuracy of your results is the quality of your training data. Therefore, make sure to take your time when collecting ROIs. 
The amount of ROIs for each class should be proportional to the total area of that class in the image.  If you have more forest than water, then you should have more ROIs for forest than you have for water.
Analyze your ROIs
To help you understand why some categories you are trying to map might get confused with others, you might consider plotting the spectral signatures of your different land cover classes. In this section, you should notice a few things when exploring the spectral signatures of your land cover classes. First, some classes are more distinct spectrally than others. For example, water is consistently dark in the NIR and SWIR wavelengths, and much darker than the other classes. This means that it shouldn’t be difficult to classify water correctly. Also, not all pixels in the same classes have the exact same values, there is some natural variability! These following steps will help you begin to understand the inherent variability of your land cover classes.  
Another factor that will strongly influence the results of your classification is the map class variance. For example, classes with high variance will tend to include more places in the map than you’d like. Similarly, if you use only very small and limited sites as an ROI for a class, you may get extremely low variances and the class will be underrepresented in your map.
The user interface of the ROI Explorer plugin should appear docked in the right side of QGIS. 
If the ROI Explorer interface is not open, right click on any QGIS toolbar and activate the ROI Explorer from the toolbar menu dropdown list.
Note: you have loaded the ROI Explorer plugin within the supplied QGIS install version. If you need to load this on your own at some later date (or it’s not showing up on the installation) – simply open the Plugins menu and click Manage and Install Plugins. Under the Installed tab, enable the ROI Explorer plugin. If this plugin is not currently installed, you may need to install it from the All tab. If it is not showing up as an option, go to Settings and choose to show also experimental plug ins. 
The ROI Explorer user interface tracks all raster and vector data opened within QGIS. Select from the Raster drop down box the 2008_mask_subset, the raster image you want to use for the classification. 
Using the Vector drop down box, select ROI_1 - the vector layer containing your training data regions of interest. 
Use the ROI “Aggregate features by field” drop down box to select the field (column) within your training data vector file that contains the training data labels- Class. This selects the field that is used to aggregate features into class labels for plotting graphs in the bottom window.
Select the first row in the table, and drag the mouse down to highlight all rows.
Click the Update button.
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Note: if your graph does not look similar to the one above, you may have to configure your visualization. Click the Configure subplots button and adjust the slider bars until you can easily see the spectral signatures. You can also select the Tight Layout button to automatically configure the plots.
[image: ]
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If you’re interested in investigating one ROI, you can select that row in the table and press the Update button again – you will now see data plotted for only that ROI.
You may select more than one feature by using the Control key and clicking additional features, by using the Shift key to select a range of features, or by using the Control + A shortcut to select all features.
Click the Update button below the plot to calculate the mean and standard deviation of all raster bands for each unique class label (like water). The plot will update and display the mean as a point on the plot with the error bars around the point representing one standard deviation in either direction. 
Continue to analyze your ROIs for spectral separability. Highlighting ROIs from different classes in the attribute table provides an understanding of differences in signatures between land cover classes. 
You might also want to analyze the within-class variability of your ROIs. (Optional) create another field within your vector layer that provides additional class information, such as degraded, growing, or mature labels for examples of forests, or simply provide a unique identifier for each example of forest. 
If you select this additional field within the ROI “aggregate features by field” down box, then you could analyze the differences among these forest sub-class examples by highlighting only features labeled forest and by clicking Update.
[bookmark: _Toc433024640][bookmark: _Toc505765507][bookmark: _Toc505765538]Classification using Machine Learning Algorithms (random forests)
There are a number of supervised classification algorithms that can be used to assign the pixels in the image to the various map classes. The one you will be using today is Random forests. The selection of features used to train any statistical model should be well thought out and informed by your knowledge of the phenomenon of interest. Here you kept the selection pretty simple, focusing on metrics that are associated with water, impervious surface, and vegetation spectral signatures.
Note on setting Features (predictor variables to train random forests model): The land cover classification pilot project in the Philippines undertaken by Deutsche Gesellschaft für Internationale Zusammenarbeit Gmbh (GIZ)[footnoteRef:1] (located in Supporting_Documentation folder in your Flash Drive) showed that agricultural lands were better classified if the lower and upper range of NDVI values over the growing season were included in the classification process. These two values are represented in this project as the 10th and 90th percentile value of NDVI over a two year period (this was specified in the Earth Engine script that generated the cloud free composite). [1:  2013 Deutsche Gesellschaft für Internationale Zusammenarbeit Gmbh (GIZ) Landsat Land Cover Classification Leyte Island, Eastern Visayas, Philippines. GIZ: Manila, Philippines.] 

Also, if there are other ancillary data sets available that can help to differentiate land cover classes, it would be good to load this into the project and include them in the model. Examples of additional data sets that would probably be quite helpful to differentiate classes include climatic and topographic (aspect, elevation) information. 
There are many ways to try and improve land cover mapping efforts beyond setting high quality regions of interest, reference data, used to train the model.  Using improved or more appropriate classification algorithms, exploring object based approaches opposed to pixel based approaches, or being more creative with specifying the model predictor variables.  In the case of being more creative with model predictor variables you can try using multiple dates of data (instead of a single date), or try using texture bands. The possibilities are many and should relate back to the nature of the classes you hope to map.  Last but certainly not least is to improve the quality of your training data. 
One way of performing a supervised classification is to utilize a Machine Learning algorithm. Machine Learning algorithms utilize training data to efficiently learn how to classify pixels. Using ROIs, these algorithms can train a classifier, and then use the relationships identified in the training process to classify the rest of the pixels in the map. 
One Machine Learning algorithm that is particularly popular in remote sensing is Random forests.  A Random forests algorithm creates numerous decision trees for each pixel. Each of these decision trees votes on what the pixel should be classified as. The land cover class that receives the most votes is then assigned as the map class for that pixel. Random forests are efficient on large data and accurate when compared to other classification algorithms. 
To complete the classification of our subset image you are going to use a Random forests classifier contained within the Orfeo toolbox in QGIS. But first, you must train the classifier using the regions of interest you just collected.
Remove bands from the composite stack 
You will use the cloud free composite bands as predictor variables in the land cover classification model. First you have to remove the ancillary bands – those that you don’t expect to supply predictive power for the land cover classification process. You will make two new stacked images. The first will have only the Landsat bands (bands 1-6 in the cloud free composite); the three NDVI bands and count will be dropped. Then you will repeat this but keep the Landsat bands and the three NDVI bands- you will just be dropping the count band. 
Open the Translate tool by clicking on Raster > Conversion > Translate (Convert Format)…
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Select the 2008_mask_subset layer as the Input Layer.
Save the Output layer in C:\Data\Images\imagery_subset. Name it 2008_sub_6band.tif.
Now select the Edit pencil at the bottom of the screen
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You will type in the bands you are interested in saving to the raster stack in the script in the lower panel of the screen. Type the text, found on the yellow line below, in between gdal_translate and –of in the script window. It is important to type it in (or copy and paste) exactly as it appears below, as the spaces are important. When you are done, you script box should appear as the image below. Make sure there is a space between the -b 6 and the –of.
-b 1 -b 2 -b 3 -b 4 -b 5 -b 6 
[image: ]
Then click OK to create the new file.
Repeat these steps to get a stacked raster with the 6 Landsat bands and the three NDVI bands. 
Name this file 2008_sub_9band.tif.
The code you will enter is found below.
-b 1 -b 2 -b 3 -b 4 -b 5 -b 6 -b 7 -b 8 -b 9
Close the Translate window.
Train the classifier
Make sure that the image you intend to classify and the vector file containing the ROIs are added to the Layers panel.
To find the tool needed, go to Processing > Toolbox (this may already be docked on the right side of the screen with the ROI Explorer).
In the toolbox that pops up on the right side of the screen double click Orfeo Toolbox > Learning > TrainImagesClassifier(rf).
If the Orfeo Toolbox isn’t an option in the Processing Toolbox, you’ll need to use the drop down menu at the bottom of the Processing Toolbox to select the Advanced interface.
Note: Orfeo has many different types of machine learning classification algorithms. The algorithm can be changed from random forests to another by choosing a different classifier from the Orfeo toolbox in this step. 
For the Input Image List, select your 2008-2010 Subset Landsat composite image, 2008_sub_6band. 
For Input Vector Data List select your ROI shapefile, ROI_1.shp. 
Make sure the Name of the discrimination field is the name of the integer attribute you used to differentiate the classes (it should be id). 
For Output Model, click Save to file… and save it as a run1.txt file in C:\Data\Models.  Note, make sure you type the .txt extension when typing in the name.
For now, leave the other fields as they are.  These are different parameters to specify how the random forest model is specified. If you’d like, play around with different parameters and see how they affect the end results.  When doing so, you will need to retrain the classifier with new output models.  
To train the classifier click Run.
Note: There were some issues running Orfeo on some operating systems. If you run into problems, you can try to set up QGIS with the Virtual Machine (VM) option supported by researchers and instructors at the Boston Education in Earth Observation Data Analysis at Boston University. The files to get this set up are large, so you will need access to high speed internet to complete the Virtual Machine setup. 
Visit the following website to learn how to set up a Virtual Machine and download the necessary files here: https://github.com/beeoda/tutorials/tree/master/1_Introduction  
Apply the random forests model to classify the image
You should now have a text (.txt) file saved that contains all the information needed to classify your image. Now the Random forests classifier can use the information in this model and apply it to the rest of the pixels in the image.
To find the tool needed for classification, return to the Processing Toolbox and go to Orfeo toolbox > Learning > Image Classification.
For Input Image select your Landsat image (2008_sub_6band.tif); 
For Model file select the text file you created in the step above (C:\Data\Models\run1.txt); and
For Output Image select Save to file… and save as 2008_LC.tif in the C:\Data\Images\imagery_subset folder. 
Leave the rest of the fields as they are. Your Image Classification box should look something like the image below. 
Select Run.
You may notice that the name present in the Layers Panel is not the same as the file name you just specified. However if you examine your output folder you will notice the file exists.
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Right click the new layer in the Layers Panel > Properties > Style to change the name and color of the classes. 
Render type: singleband pseudocolor
At the bottom of the Band Rendering box:
Mode: Equal interval
Classes: the number of land cover categories you included in your classification scheme  - I had four (forest, water, fallow/other, ag)
Select Classify
Now in the box on the left (with the values, color swatches and labels) you can double click on any of these to edit them. 
Edit the labels to be text values – e.g., change ‘1’ to ‘forest’, etc.
Double click on each color swatch to change it to a color that matches land cover expectations (e.g., water is usually set to a blue display, etc).
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Select OK to apply the updated settings to view your classification.
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Note: Most likely, the map will not be satisfactory and you will need to go back to Part 3 to revisit and edit your ROIs. Remember, image classification is an iterative process with a lot of learning by trial and error. You may find you have to add/remove/edit your ROIs several times before you have a map that you are satisfied with.
[bookmark: _Toc433024641]How do you know if your map is satisfactory? Good question, you will delve into that next.
[bookmark: _Toc505765508][bookmark: _Toc505765539]Examine your map
Now your classified image should be displayed as a layer in QGIS. Each different class will correspond to the number you gave that class when creating the ROIs. Look around at the classified image – are you happy with the results? If not (and you won’t be the first time), you need to revisit your training data. Some classes are bound to be “too big” and others “too small”. If a class is too small, it will help to add a few more training sites for better characterization of the within-class variability. As a rule of thumb, if you have lots of pixels in a class, it will tend to have higher variances, and tend to be “too big” in your results.  You will need to spend quite a bit of time looking over your results and modifying your sites to get a good result. One common problem is that there may be land cover classes in the image that you haven’t included in your legend, and those areas will be poorly classified. So you might need to add a class or two.
If the results of the classification are not satisfactory, you may want to investigate the quality of your training samples. Things to consider include:
Quality: Are the existing training samples that were created from the training shapefile correct? For example, if your ROI is mostly forest but includes a small section of river it will be better to remove it and replace it with one that is composed of pixels that represent only forest. Eliminate and replace any problem samples.
Homogeneity: is the variance of spectral signatures high in any of your land cover classes? Or is your data distributed with a bi-modal distribution (or multi-modal)? If so, maybe consider splitting a broad category into a couple of subcategories (e.g., splitting a single agriculture class into vegetated crops and fallow / flooded). This might be important to do with commonly confused subclasses, such as mangroves or rice paddies.
Quantity and representation: Do you have enough training points? Do your training data points cover the full range of variability of a land cover class? For example, does your water class include information for the sea, lakes, and rivers? If not, you may need to create additional training data. You can do this by editing the training data shapefile.
[bookmark: _Toc433024642](Optional) Repeat the classification using the layer stack with the three NDVI bands
Use what you learned in the previous steps to run a land cover classification using the random forests algorithm. This time, specify 2008_sub_9band as the input file instead of the 2008_sub_6band.  Note you will have to create a new random forests model using the same ROIs but with the 9band image, Part 4 step B.
Name the output 2008_LC_ndvi.tif.
Do you notice any differences in the land cover classification output?
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[bookmark: _Toc505765509][bookmark: _Toc505765540]Refining the map using a Sieve
When examining your map, you may notice a “salt and pepper” effect in some of your classes. This refers to lone pixels of a class inside a large, otherwise homogenous class that act to make the map look “noisy”. Chances are these pixels should be classified as the majority class that surrounds it. If this is occurring in your map and you are confident these pixels are the result of classification errors then they can easily be removed. A technique often used in remote sensing is to ‘sieve’ isolated pixels and replace them with the classification of the majority class that surrounds it.
Map smoothing/clean-up using a Sieve
In the general QGIS toolbar, go to Raster > Analysis > Sieve. 
For Input file select your classified image (2008_LC.tif or 2008_LC_ndvi.tif).
For Output file save your file as 2008_LC_Sieve10.tif in C:\Data\Images\imagery_subset. 
For Threshold put 10. This defines the minimum size of pixel groupings. Adjust this if you would like to remove larger or smaller groups. 
For Pixel connections select 8. This will take the information from the 8 adjacent cells into account. Start with 8 now, then if you are interested in exploring how this parameter influences the results feel free to change the number and re-run. 
Press OK to run the sieving process. 
Then Close the dialog box.
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Copy the display style from the 2008_LC layer (in the layer panel, right click on the 2008 classified image and select Styles > Copy Style). 
Paste this style onto the Sieved raster (in the layer panel, right click on the 2008 sieve classified image and select Styles > Paste Style).
Notice a change in your classification map? It should look less noisy. Below you can see a subset of a classification unsmoothed (left) and smoothed using the sieving process (right).
[image: ]
Recall the IPCC forest definition (refer to Part 2 for a refresher). How could you use the sieve function to modify the forest classification to match the minimum forest size threshold from the IPCC definition?
What are the implications of using the sieve function if your goal is to monitor encroachment of forestland by small scale settlements? Or the re-greening of small areas in an urban environment?
[bookmark: _Toc433024643][bookmark: _Toc505765510][bookmark: _Toc505765541]Image Segmentation
One additional step you can do in the classification process is to classify segments instead of individual pixels. This can be advantageous if you are finding your classification image to be overly “noisy”. Image segmentation algorithms look for clusters of similar pixels in an image and group them together based on pre-determined criteria. In doing so, you lose the spatial resolution of the image but can create a simpler image that’s easier to work with. In addition, the shape, size, and spectral variance of a segment can aid in the classification process. 
The clusters reveal changes at the landscape level, which is why segmentation is often used in both manual interpretation and automated algorithms for change detection. There are numerous algorithms for image segmentation, but the one you are going to use is called Mean-Shift Clustering. Mean-shift analysis is a non-parametric clustering technique that is widely used in image processing. The algorithm assumes that the spectral values in the image are sampled from an underlying probability density function. The dense clusters of data are therefore assumed to correspond with the modes of the underlying density function. The algorithm makes no assumption about the number of modes or size of output clusters. 
While the segmentation process can be computationally intensive, it can reveal additional information about the landscape that is not present at the pixel level. Primarily, it allows spectral variance to be utilized in the classification process. The output of the segmentation described in this tutorial is an image that is made up of segments determined by the Mean-Shift Algorithm. The segments contain both the mean and the variance of the pixels that they contain. This image can then be classified in the same way described in the previous sections.
Image segmentation
Be sure that you have the subset image open in QGIS. Since image segmentation is a computationally expensive process, it is best to first work with a small subset to test the parameters you will use.  At most, start with an image that is a few thousand pixels. If your image is significantly larger that, use Raster > Extraction > Clipper to make a smaller one. This will save you significant time in the long run. Once you have determined appropriate parameters, then segmentation can be run on the full scene. 
In the Processing Toolbox, go to Orfeo Toolbox > Segmentation > Segmentation (meanshift).  
Under Input Image select the subsetted image with the NDVI bands (2008_sub_9band.tif). 
You might have to tweak the parameters a bit to get the results you are looking for. Here are some suggestions:
Spatial radius: the size of a window (in pixels) being considered in mean calculation; to start leave this at 5.  
Range radius: specifies how close, in terms of Euclidian distance, neighboring pixels need to be to be grouped together; to start, try keeping it at 15. 
Mode convergence threshold: Neighboring pixels whose multi-spectral distance lies below this threshold with converge into one mode. Leave this at 0.1. 
Maximum number of iterations: Algorithm will stop if convergence has not been reached at this amount of iterations. This can impact computation time. If you want to speed up the process at the expense of segment quality, decrease this value. To start, keep this at 100. 
Minimum region size: This is intuitively the smallest an output segment can be. This will depend on the types of regions you are trying to find. Increase this to 150. 
Tile size: Since the algorithm is so computationally expensive, it will break up in the image into specified tiles to reduce the memory needed. This can result in the output segment image looking ‘blocky’ since segments are not accurately calculated at the lines between the segments. This will often not matter, but if the blocks are jeopardizing your results, increase this value. If you are running into memory issues, decrease this value. To start, keep it at 1024. 
Save the Output vector file as Segments_08v1.shp in the folder: C:\Data\Images\imagery_subset. 
Keep everything else the same, and click Run. 
Depending on the size of your input file, this process can take a while. For the 2008_sub_9band image, it took a little less than a minute to run on my desktop. 
Once it is done running, you should get something like the following image, the white lines are the output segments (a vector file) overlaid on the original Landsat image. You may need to change the display style (see instructions below) to assess the output. 
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To set the display to just the segment outlines, right click the shapefile in Layers Panel > Properties > Style > Simple Fill > set Symbol layer type to Outline: Simple line.
Change the outline color to white, or another color that has high contrast with your underlying image.
One use of image segmentation is to identify spectrally varying regions in a normally homogenous land cover. Through visual interpretation, this can help detect areas of change.
Layer stack for input to classify land cover of objects (segments) 
For classification, the vector file needs to be converted to a raster. Using zonal statistics, a raster can be created that contains the mean and variance of the pixels within each segment as the output bands. This ‘object’ image can then be classified. 
To calculate mean and variance for the objects in your image you will use a script that must be run in the command line, outside of QGIS. Double click on the OSGeo4W Shell Shortcut that you copied onto your desktop earlier in the training course to open the OSGeo4W command line shell. 
Navigate to the folder where we’d like to save the data. You can do this a couple different ways. 
You can copy the code below. Paste it into the command line shell by right clicking your mouse.
 Cd C:\Data\Images\imagery_subset
Or this: you can type ‘cd c:\’ in the command line and enter the first characters of the path and use the tab key to autofill – then press enter:
Cd C:\Data(tab) … etc, etc
Next you will run the script. First you specify python. Then the full path name to access the script ‘object_stats.py’. Then you enter the Landsat image, the segment vector, and the statistics to be calculated (mean and variance in this case). 
For this exercise, you can just copy the text below. 
Right click in the command line shell to paste the text.
python C:\QGIS_Scripts\object_stats.py C:\Data\Images\imagery_subset\2008_sub_9band.tif C:\Data\Images\imagery_subset\Segments_08v1.shp C:\Data\Images\imagery_subset\2008_seg_stats.tif mean var
Note: Instead of typing the full name in as you work with command line, you can also drag the files from Windows Explorer onto the command line to get the full path name of scripts and files (without typing them in by hand). 
A dialogue box will open that informs you that python.exe has stopped working. This is OK your layer was created, so Click OK to close the program and proceed.
The process you just initiated will generate a multiband image where each segment contains the mean and variance for the pixels in that segment in the following band order:
- Mean Band 1 (blue), Variance Band 1 (blue), Mean Band 2 (green), Variance Band 2 (green), etc…
Load the generated stacked segment statistics file (2008_seg_stats.tif) into your QGIS project (Hint: Layer > Add Layer > Add Raster Layer… ). 
This raster can now be used in an object-based classification approach; display it as false color composite of choice, it should look like the image on the right below. The original Landsat image (swir, nir, red {6, 4, 3} false color composite) appears on the left and mean segment image (swir, nir, red {11-7-5} false color composite) on the right.
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Note: for the stacked segment statistics file, the SWIR, NIR, red false color composite bands are 11-7-5 instead of 6, 4, 3 since band1 is the mean of Band1 (blue), band2 is Variance for Band1 (blue), etc.
Run random forests on the segment layer
Use what you learned in Part 4 of this exercise to run a land cover classification on the stacked segment statistics data set (2008_seg_stats.tif).
Name the output random forests model runSegments.txt.
[image: ]
Name your classified image 2008_LC_segments.tif.
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Use the same display style to view the output as you did for the pixel based classification (tip: you can copy and paste styles). 
Toggle the new classification on and off to compare to the previous classification (the pixel based and the pixel based classification that was cleaned up using the sieve process). What are the major differences between these three methods?
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Note: The results of the classification of the segments may result in some over-classification errors (commission), as seen in the graphic above. Think back to when you were creating your ROIs – you were probably making very general shapes, and it is very likely that some of the polygons you created overlap multiple segments. If your ROI actually includes segments from multiple land cover types, this could negatively affect your classification results. Based on the output above, I may want to go back and revise my ROIs for the ‘other’ land cover class to make sure that they do not include forested areas or other land cover types. 
Alternatively, my minimum segment size may have been set too big. Some of my segments appear to include multiple land cover types. You can also adjust the segmentation process to create more homogenous segments before running the classification process, such as random forests.
Map clean-up through segmentation
In Part 6 you sieved out isolated groups of classified pixels and replaced them with the group majority of the pixels around it. This made the map appear less noisy while still retaining the geometry of the features in the map. An alternative method to cleaning up a map is to use image segmentation to assign classifications at the segment level instead of at the pixel level. In the previous step, zonal statistics were used to gain information about the segments and perform object-based classification. This is not the only way segmentation can be utilized in classification, however. 
An alternative to classifying objects based on the original Landsat data is to classify the map at the pixel level and use the segmentation results to clean up that classification. In this process, no means or variances are calculated. Instead, each pixel is classified normally. The mode, or most likely classification, for each segment is then calculated. These modes are then assigned to each segment and used as the output classification map.
Return to the OSGeo4W Shell (double click on the OSGeo4W Shell shortcut on your desktop if the Shell isn’t still open).
If the Shell isn’t pointing to the imagery_subset folder, navigate to that directory (hint: refer to Part 7, Step B). 
You will use the object_stats.py script again. This time, instead of extracting statistics from the Landsat image use the original (non-segmented) pixel-based classification map from Part 4. 
The segmentation vector will again be used, but this time specify ‘mode’ as the statistic. What this is doing is calculating the classification that has the highest likelihood of being assigned inside that segment and applying that classification to the entire segment. This has the effect of “smoothing” out the classification map based on calculated segments. An example command would be:
python C:\QGIS_Scripts\object_stats.py C:\Data\Images\imagery_subset\2008_LC.tif C:\Data\Images\imagery_subset\Segments_08v1.shp C:\Data\Images\imagery_subset\2008_LC_Pxl_Seg.tif mode
Note: if you get a message about the tuple index being out of range (see example below), it is likely due to an error in the path name of one of your files. In the example below, there is an extra space in the path name where the segments shapefile is being called. 
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If you get a warning message with a runtime error following a Create line about deleting the output file, followed with a permission denied line, you need to change the name of the output file in the script. You can’t overwrite an already existing file.
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Add the new raster (2008_LC_Pxl_Seg.tif) to your QGIS project and adjust the display style to match the other land cover classification results.
The result is a “clean” map like the one on the right in the image on the following page, with the original unsegmented map to the left (note: if this removes too much detail, you will need to redo the segmentation and decrease the minimum region size).
[image: ]
Save your project.

[bookmark: _Toc437437282][bookmark: _Toc508631578][bookmark: _Toc508632693][bookmark: _Toc508632733][bookmark: _Toc428784178][bookmark: _Toc428784356]Exercise 5: Change Detection
[bookmark: _Toc508632670]Introduction
The goal of this assignment is use what you have learned so far during this training course to produce a change map. It requires two dates of imagery that are sufficiently far apart for change detection. You will call these two images Date 1 and Date 2. 
You can choose to study forest loss and/or regrowth or any other land change process. 
There are various methods of change detection, all with their pros and cons. This online training course will introduce you to just a few, which may or may not be suitable to your needs in the future. 
Historically, the most common method of change detection in remote sensing has been post-classification comparison. Using this method you would classify two maps separately, and create a change map out of where they differ. While this is computationally efficient compared to other methods, it is not recommended and will not be utilized in this training course. There are a few reasons why this is not recommended:
1. Errors in the change map are multiplicative from the errors of the two classified single-date maps. Since the accuracy of the change map is directly dependent on the accuracies of the parent maps, overall change accuracy tends to be low. This often results in over-estimated total change area.
2. This method tends to ignore subtle changes within a class. It is difficult to study classes such as degradation and regrowth when change is solely based on map classification. 
For these reasons, we recommend creating change maps based on changes in the raw data instead of changes in maps. In this exercise, you will learn how to directly classify change based on the information in both of your images.
[bookmark: _Toc508632671]Objectives
· Make sure you start with two cloud-masked images from different dates.
· Create a multi-temporal transform to help locate areas of change in your images. You will be introduced to a few possible methods that highlight the differences in the images.
· Create ROIs for your map that contain samples of stable classes and regions of all the change classes you have defined for your final change map.
· Produce a change map. Like creating your classification images, this may take a few tries to perfect.


1. [bookmark: _Toc433879476][bookmark: _Toc505766100]Setting up the time 2 Image
Project Set up
Open QGIS by double-clicking on the QGIS shortcut on your desktop.
Load the two cloud free composite rasters - not the classified maps you made yesterday. 
Click on the Add Raster Layer Button.
Navigate to the C:\Data\Images folder and select the file called Cambodia_SR_2008_2010_305_90_Composite.tif. 
Repeat to load Cambodia_SR_2013_2015_305_90_Composite.tif.
Note: If, instead of working with the cloud free composite generated in Google Earth Engine, you decide to work with raw Landsat Data, you will need to create a stack of the second image (Date 2) – after removing clouds and converting to reflectance values. Also make sure that the stack contains the same bands as the Date 1 stack. You’ll need to pay special attention to this if one of the images is a L8 image and the other a L5 or L7 image. 
Load the subset images
Use the subset image that you created previously in Exercise 4 – Land cover classification.
Click on the Add Raster button.
Navigate to C:\Data\Images\imagery_subset\2008_mask_subset.tif and click Open.
Subset the 2013-2015 cloud free composite.
Go to Raster > Extraction > Clipper.
Cambodia_SR_2013_2015_305_90_Composite.tif as the input file.
Set the output file as C:\Data\Images\imagery_subset\2013_mask_subset.tif.
Set the Clipping mode to Mask layer.
Set the Mask layer as Processing_Subset (found in C:\Data\ Shapefiles\).
Hit OK to execute.
Close the Clipper dialog box.
Remove bands from the layer stacks
You will need to remove the ancillary bands from the new layer stacks. You will make two new stacked images for 2013. The first will have only the Landsat bands (bands 1-6 in the cloud free composite); the three NDVI bands and count band will be dropped. Then you will create a new stack, keeping the Landsat bands and the three NDVI bands – you will just be dropping the count band. 
Open the Translate tool by clicking on Raster > Conversion > Translate (Convert Format)…

[image: ]
Select the 2013_mask_subset layer as the Input Layer.
Save the Output layer in C:\Data\Images\imagery_subset. Name it 2013_sub_6band.tif.
Now select the Edit pencil at the bottom of the screen
[image: ]
0. You will type in the bands you are interested in saving to your raster stack in the script in the lower panel of the screen. Type the text, found on the yellow line below, in between gdal_translate and –of in the script window. It is important to type it in (or copy and paste) exactly as it appears below, as the spaces are important. When you are done, your script box should appear as the image below. Make sure there is a space between the -b 6 and the –of.
-b 1 -b 2 -b 3 -b 4 -b 5 -b 6 
[image: ]
Click OK to begin processing.
Click OK and then OK again when the processing is completed to close message dialogs.
Click the pencil button again to turn editing off and edit the Output file name.
Repeat these steps to get a stacked raster with the 6 Landsat bands and the three NDVI bands. 
Name this file 2013_sub_9band.tif.
The code you will enter is found below.
-b 1 -b 2 -b 3 -b 4 -b 5 -b 6 -b 7 -b 8 -b 9
Save your QGIS project
Remove the intermediate image files such that the only rasters loaded in your project are the 2008 9- and 6-band images and the 2013 9- and 6-band images.
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Save your project as Change_Det.qgs in the folder QGIS projects folder (C:\Data\QGIS_Projects\).
Display the subset images in matching stretches
Pick a stretch that you like (one suggestion would be swir, nir, red (6, 4, 3) false color composite). Apply this stretch to one of the subset images.
Right click on the image name under Layers and go to Styles > Copy Style.
[image: ]
To apply this matching stretch to your other subset image, right click on the second image and go to Styles > Paste Style.
[bookmark: _Toc433879477][bookmark: _Toc505766101]Single-date transformations
Explore differences in your data
Toggle back and forth between your images (uncheck the box next to the top subset image in the Layers panel). Zoom in and pan around if needed. Are there any distinct areas that seem to be changing? 
Large changes are likely to be visible by doing this, but small changes will not be. Even large changes can be difficult to detect by just comparing the original images. One method to help changes stand out more clearly is by creating a multi-temporal transform. 
To do this, you must first decide on what type of transformation you would like to do to your imagery. There are different types of transforms, each with their own advantages. By creating a transform you are leveraging multiple bands of information in an image to highlight specific information that you are looking for. The transformation that you do should correspond with what type of change you are looking for.
Use the tables below to guide you in deciding what transformation you would like to do. This is just a small list of some of the more common transformations, but it by no means includes them all. Once you have decided on a transformation, you will perform it on both images. The difference in the resulting images will be your multi-temporal transformation. 
[image: ]
Note about Tasseled Cap: the Tasseled Cap transformation was designed to transform spectral bands to new uncorrelated bands representing three distinct phases of vegetation: brightness, greenness, and yellowness (or wetness). The coefficients that have been calculated for the transformation are different depending on which sensor you are using, and whether you are using surface reflectance or TOA reflectance. Since you are working with a composite of Landsat 5, 7 and 8 this creates more complexities in the workflow so you will not use this transform during the course.
3. NBR Single-date transformation for Date1 image
Open up the Raster Calculator in QGIS, located in Raster > Raster Calculator.  This tool allows you to perform calculations on the pixel values of raster files.
Note: Under Raster bands you will see a list containing each band of each raster file you have opened in your Layers. The listing that ends in ‘@1’ corresponds to band 1 of the corresponding file, ‘@2’ is band 2, and so on.
Using the equation for the NBR transformation, write the expression under Raster calculator expression panel. 
Instead of typing in each band name, double-click the band name in the Raster bands panel to automatically add it to the Raster calculator expression panel.
Save the output layer in C:\Data\Images\imagery_subset. Name it something that makes sense like 2008_nbr.tif.
Your Raster calculator box should look something like this expression, which is calculating NBR:
[image: ]
To perform the calculation, click OK.
The output file is a NBR transformation for your 2008 image. If you’d like, stretch the transform image appropriately and compare it to one of your Landsat images.
To apply a single-band stretch right click on the file and go to Properties > Style.
Under Render type select Singleband pseudocolor.
Select a color scheme you are happy with.
Click Classify to apply the color stretch to the single-band image.
Click OK and the color scheme and stretch should be applied to your transform.
Switch back and forth between your transform and your Landsat image. How do the transformed values relate to what you know about those areas? Do the transformed image layer values vary between forest cover and built up lands? 
Single-date transform for Date2 image
Repeat these steps for your second image, 2013_sub_9band. 
Copy the style from the 2008 transformed image and paste it to the 2013 image (hint: right click on the layers in the Layers Panel).
Toggle back and forth between the 2008 transformed image and the 2013 one. Do you notice any differences?
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[bookmark: _Toc433879478][bookmark: _Toc505766102]Multi-temporal transform, or difference layers
Now that you have two single-date transformations, you can use them to create a multi-temporal transform, or a difference layer. Since these indices are used to highlight information in the individual images, differencing them will help highlight areas of change between the images.
Open up the Raster Calculator in QGIS, located in Raster > Raster Calculator.  
In the Raster calculator expression box, write an expression that subtracts the date1 (2008) NBR transformation from the date2 (2013) NBR transformation. 
Use an appropriate name like NBR_diff.tif in C: \Data\Images\imagery_subset for the file in Output layer.
Your Raster calculator box should look something like this expression illustrated below, which is calculating a NBR difference:
[image: ]
To perform the calculation, click OK.
In the difference layer, or multi-temporal transform, the large positive and the large negative values are an indicator of change. While the values close to 0 likely represent no changes- at least no changes in land cover that the NBR transform is sensitive to. 
Apply a singleband pseudocolor render type and stretch to the multi-temporal transform, named NBR_Diff.tif. Select a color gradient that reflects both the high and low extreme values and has values close to 0 assigned a light color.
Remember to select the Classify box to update the values in the dialogue box.
You can double click on the values in the Value field to the left of the color swatches to manually update interval values. 
Make sure you repeat this for the labels so that they all match.
Select OK.
Refer to following image for an example.
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Note: A large difference value (either dark red or dark blue) is an indication of land cover changes occurring between the two images. 
Investigate the multi-temporal transform image, in addition to the Landsat images. Where are some clear examples of change? Which areas seem to have stable land cover between the two years? 
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Add in the Change_Examples.shp shapefile. It is located in the C:\Data\Shapefiles\Data_Exploration folder. 
Change the fill color to transparent with a dark border that is visible on the color ramp scheme you selected for the multi-temporal transform (difference layer).
Click Simple Fill
Select the Fill dropdown menu and choose Transparent fill
From the Outline dropdown menu, select black or a similar color. 
Set the Outline width to 0.5
Select OK.
[image: ]
You might need to move this layer to display on top of the NBR difference layer, depending on the order that the layers loaded into the Layers Panel.
Next examine the map window. What do the difference values look like in these example change areas? Why do some areas have positive difference values, while others have negative values?
[image: ]
If you’d like to see what these areas look like using the aerial imagery library in Google Earth, you can navigate to the data folder and double click on the kml file called Change_Examples.kml in C: \Data\Shapefiles\Data_Exploration. This will open Google Earth with the same shapes you have loaded into QGIS – in a Temporary Places folder. 
If the time slider isn’t loaded by default you can click on the show historical imagery icon. 
[image: ]
Once the slider appears, you can slide along the timeline to see the available archive of aerial photos and investigate what kinds of changes are occurring in these sample regions.
[image: ]
[bookmark: _Toc433879479][bookmark: _Toc505766103]Advanced Multi-Temporal Transforms
Principal Component Analysis
One slightly more advanced method of data exploration that can be utilized in change detection is Principal Component Analysis (PCA). PCA transforms the data along orthogonal axes of variability in spectral space. In other words, PCA transforms the spectral bands into new variables that are uncorrelated with one another. Since the spectral bands are highly correlated, this can be a way of reducing the amount of variables needed to produce the same amount of information. The Principal Components are ordered so that the first few will contain the most variation from the original variables, while the last few will contain the least.
One way of using PCA for change detection is by performing it on a multi-date image stack. Since areas of change will have low correlation between all the variables (spectral bands) when compared to stable pixels, these changes will be accentuated in the Principal Components. The output of doing so will be a Principal Components image with N number of Components (with N representing the number of bands in the multi-date image stack). Since changed pixels will have the highest variation, these Components will be largest in areas of change. To perform a PCA, first stack your two Landsat images.
Note: you can run this on either the 6 band stacked images or the 9 band stacked images. Remember, the 9 band stacked images will provide information about the differences in NDVI values over the season (90th and 10th percentile NDVI value over the growing season). Using information about NDVI has been reported to better map subtle changes in agricultural lands – depending on the type of crops being grown (GIZ 2013). The instructions are for the 6 band – just the stack with the Landsat bands, but you can simply change the input files to the 9 band and run with the NDVI information.  
First you need to stack the two images together. To create a layer stack of your images, click Raster > Miscellaneous > Merge. This will open the Merge dialog. 
Click Select to the right of Input files. Select the two subset cloud free Landsat composite images: 2008_sub_6band.tif and 2013_sub_6band.tif, both in C:\Data\Images\imagery_subset. 
Click Select to the right of Output files and navigate to C:\Data\Images\imagery_subset. Provide an appropriate file name, like sub_2008_2013_6band.tif for example.
Check the box next to Place each input file into a separate band.
Leave all other options as is.
Select OK. 
This will add the stacked image to the QGIS canvas.
Click OK to close the Finished message and the qgis-bin message, and then click Close to close the Merge dialog box.
Note: This is also possible via the QGIS command line shell using gdal_merge.py. When doing this, the ‘-separate’ option must be specified to create a layer stack (see http://www.gdal.org/gdal_merge.html for documentation).
Return to the Processing Toolbox to open the PCA tool. If it is not available, go to Processing > Toolbox. Once open, go to Orfeo Toolbox > Image Filtering > DimensionalityReduction (pca).
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For the Input Image select your multi-date image stack (C:\Data\Images\imagery_subset\sub_2008_2013_6band.tif). 
The number of components depends on the number of input features, but for the multi-temporal stack of 12 bands, 6-8 components are recommended. 
Uncheck the box that says Normalize. This function normalizes the variance of the different variables. This is useful if your variables are in different units (meters and grams). 
Click the … button next to Output Image and choose to save to file. Give it an appropriate name (e.g., PCA_sub_2008_2013.tif) and save to C:\Data\Images\imagery_subset. Click Save.
Click Run. 
Click Close to close the dialog box.
Both the Output Image and the Inverse Output Image load. Turn off or remove the Inverse Output Image.
Note: The layer is automatically loaded into the QGIS project with a Multiband color display image for Band 1, 2, 3. Both the Output Image and the Inverse Output Image load.
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The resulting image has several principal components (6-8 in this case). The first layer represents the value for each pixel along the first principal component axis of variability. Often, this represents the overall variation in reflectance in the image. The next few components (next few bands) might be where the change is noticeable.
Zoom into the sample areas of change (from the Change_Examples.shp file). Then set the display of each PC band individually to see if any of them capture the change. Start with Band 1.
Right click the PCA stack in Layers panel > Properties > Style. 
Set the Render type to Singleband pseudocolor. 
Change to Band 1 (Gray). 
Select Classify.
Apply the changes.
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Repeat with Band 2. 
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Repeat with the other bands.
[image: ]
Look at areas that you assume to be stable; do any patches present themselves in any of the PC layers?
Multivariate Alteration Detection
Another method for change detection between multiple images is called the Multivariate Alteration Detector. MAD is based on the theory of conical correlation analysis, which when used on remote sensing data seeks to transform the data through linear combinations that maximize correlation between the variables. Each image is transformed into new images with layers representing each canonical variate. The first variate represents the linear combination containing the most correlation in the image, and with subsequent layers containing decreasing correlations. The theory of MAD is that by performing this linear transformation on both images, the difference between the two will accentuate areas of change in the image.
In the Processing Toolbox go to Orfeo toolbox > Feature Extraction > Multivariate alteration detector.
For Input Image 1 select your Time 1 subset (6 or 9 band) image. 
For Input Image 2 select your Time 2 subset (6 or 9 band) image. 
For Change Map, click the … button and select Save to File. Choose an appropriate file name, such as MAD_transform.tif. Save it to the following folder - C:\Data\Images\imagery_subset. 
Click Run.
[image: ]
Once you have your output map, it will load like the PCA output (a Multiband color display image for Band 1, 2, 3). It will be called Change Map.
[image: ]
Try looking at the first few layers individually. Use what you learned in the previous steps to apply a single-band (pseudo color) stretch to band 1 of the output image – repeat for the other bands as well.
Note: Areas of change should be visible in the first few bands. Does anything stick out? If there are any unusual areas where you thought it was stable, this could be areas of change. Below is an example of band 4 of the MAD image.
[image: ]
[bookmark: _Toc433879480][bookmark: _Toc505766104]Data prep for change classification
To classify change in your images, you are going to use a direct change classification approach. For this, you are classifying your images in a similar fashion to how you classified them in the previous exercise. However, now you are going to include change classes in the classification.
Select and format your NBR multi-temporal transform
Select the multi-temporal transforms that you think would be good change predictors. We will select the NBR_diff layer in this exercise, but you can select others if you like…
Next you need to prepare the raster to go from a float format to an integer format during the layer stack process. Open Raster Calculator (Raster > Raster Calculator).
Populate the Raster calculator expression box such that you are multiplying your NBR multi-temporal transform layer (NBR_diff@1) by 1000. See an example below. Name it (NBR_Diff_1000.tif) and save it to the imagery_subset folder.
Select OK.
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Next convert the output to an integer file. Open Raster > Conversion > Translate (Convert format).
Select the NBR_Diff_1000.tif as the input layer.
Name the Output file NBR_Diff_1000_int.tif.
Click on the pencil to edit. Then insert -ot Int16 in between the word GTiff and the path to the input file (see following image for an example).
Click OK to run.
Close any dialog windows that popped up after running, and click Close to close Translate.
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Stack your images with your multi-temporal transform 
Now you need to stack the input images. Create an image stack with both subset images in addition to your NBR multi-temporal transform. If you did one of the optional transforms (PCA or MAD), try including that in the stack – note: you will have to multiply each band in the PCA or MAD transform by 1000 and then convert each to a 16 bit integer format before you can stack them with the spectral bands and the NBR_diff layer. 
Use Raster > Miscellaneous > Merge.
For the input files, include the two cloud free composite subsets (either the 6 or 9 band) and any difference layers (NBR_Diff or PCA or MAD output). For example: 
2008_sub_6band.tif 
2013_sub_6band.tif 
NBR_diff_1000_int.tif
For the Output file, save it as d1d2_NBR_stack_sub.tif to C:\Data\Images\imagery_subset.
Check the box next to the option: Place each input file into a separate band.
Select OK.
Close the dialog box.
Note: the output will have 13 bands. If you followed the order from the instructions above, the first six are the six bands from the 2008_Sub_6band.tif, bands 7-12 represent the six bands from the 2013_Sub_6band.tif, and the final band is the NBR difference value (NBR_Diff_1000_Int.tif). 
Adjust the display
Set the No data value as -32768 (under Transparency in the Layer Properties). 
Use what you’ve learned during the online training course to change the image display to something you like – something that will be useful while you generate your ROI’s. For example, you could set the Band 13 (the NBR difference layer) to a Singleband pseudocolor.  
Note: This is where keeping track of what each band represents gets tricky. The bands are stacked in the order that they were ingested in the merge command. It’s helpful to keep a table that you can refer back to; include the band number, its alias, and parent data set in your notes table each time you run a merge to create a new data set. 
Define your ROIs for change classification
Use your input stack, and other data layers you’ve generated in this exercise, to locate areas of change in your image. Create ROIs for these new map classes and your old classes as well. When you are done, you should have ROIs for both the stable and the change classes. 
The change classes you choose are based upon what you are trying to study. If you are looking for deforestation, find examples of such areas and collect ROIs and label them as “deforestation”. If you want to study urbanization, include that as a change class. 
Fill in your stable and change classes in the table below (suggestions have been included in grey, but feel free to change/edit).
	Land Cover Class
	Numeric Value

	Forest (stable)
	1

	Water (stable)
	2

	Fallow/Other (stable)
	3

	Ag (stable)
	4

	Forest Loss
	5

	Forest Gain
	6

	Fallow/Other to Ag
	7

	Ag to Fallow/Other
	8


Use what you learned in the Exercise 4 to help guide you in creating appropriate ROIs (for instructions, refer to Ex 4, Part 3A).
Name your new ROI shapefile ROI_2.shp (C:\Data\Shapefiles\ROI\ROI_2.shp).
Hint: You can use the Change Examples polygons to help you track down areas undergoing changes to forestlands over time.
Assess the spectral signatures of your ROIs. Again, revisit Ex. 4, Part 3C if you need to review the ROI tool.
Note: If you’ve specified the forest loss and gain well, you should expect to see the loss (blue band below) at the lower end of the NBR difference layer (Band 13 in the stack), while gain (grey band) is at the upper end. What other differences do you see? What do you notice about the measures of variation (error bars)? 
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[bookmark: _Toc433879481][bookmark: _Toc505766105]Classify your change map
Now that you have collected your ROIs, you can classify your change map. Use the same methodology that you performed in the previous exercise. 
Train the classifier
Make sure that the image you intend to classify and the vector file containing the ROIs are in the Layers panel.
Go to Processing > Toolbox. In the toolbox that pops up on the right side of the screen double click Orfeo Toolbox > Learning > TrainImagesClassifier(rf).
Note: If the Orfeo Toolbox isn’t an option in the Processing Toolbox, you’ll need to use the drop down menu at the bottom of the Processing Toolbox to select the Advanced interface.
For the Input Image List, select your date 1/date2 stacked/multi-temporal transform image, e.g., d1d2_NBR_stack_sub.tif. 
For Input Vector Data List select your ROI shapefile, e.g., ROI_2.shp. 
Make sure the Name of the discrimination field is the name of the integer attribute you used to differentiate the classes (id). 
For Output Model, click Save to file… and save it as a run_CD.txt file in C:\Data\Models.
For now, leave the other fields as they are.  These are different parameters for what goes into the Random forests classification. If you’d like, you can play around with the different parameters and see how they affect the end results.  When doing so, you will need to retrain the classifier with new output models.  
To train the classifier click Run.
Close the dialog after it has processed.
Apply the random forests model to classify the two date image stack
You should now have a text (.txt) file saved that contains all the information needed to classify your image. Now the Random forests classifier can use the information in this model and apply it to the rest of the pixels in the image.
To find the tool needed for classification, return to the Processing Toolbox and go to Learning > Image Classification.
For Input Image select your two date image stack (d1d2_NBR_stack_sub.tif); 
For Model file select the text file you created in the step above (C:\Data\Models\run_CD.txt); and
For Output Image select Save to file… Save it with a descriptive name, such as LC_08_13_NBR.tif, in the C:\Data\Images\imagery_subset folder. 
Leave the rest of the fields as they are. 
Select Run.
Close the dialog after it has processed.
Adjust the display to see the output classes. Right click the map in the Layers panel > Properties > Style to change the name and color of the classes. 
Render type: singleband pseudocolor
Classes: the number of land cover categories you included in your classification scheme - eight if you used the following categories: (1) forest_stable, (2) water_stable, (3) fallowOther_stable, (4) ag_stable, (5) forest loss, (6) forest_gain, (7) fallowOther_to_ag, and (8) ag_to_fallowOther.
Select Classify.
Now in the box with the values, color swatches and labels you can double click on any of these to edit them. 
Edit the labels to be text values – e.g., change ‘1’ to ‘forest’, etc. Hint: use your table from Part 5 D of this exercise to update.
Double click on each color swatch to change it to a color that matches land cover expectations (e.g., water is usually set to a blue display, etc).
Select OK to apply the updated settings to view your classification.
[bookmark: _Toc433879482][bookmark: _Toc505766106]Evaluate and Refine Map
Inspect the results. 
What do your change areas look like? Did you capture the changes you expected? 
Are the areas you expected to be stable, stable in the output? 
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Are the areas marked as forest gain always a gain in forestlands? Or is a label such as re-greening or forest growth more appropriate? How about forest losses vs forest degradation? Hint: refer to the charts below to see how a measure of greenness, NDVI, values change over time with two different change agents.
[image: Ex9_changeSignals]
You can revise the map using what you learned in Exercise 4 – such as modifying ROIs and input data, using sieve, implementing object-based classification, or clean-up of the map. Redo just as you did when creating the single date land cover map until you are happy with the results.
Note: if you decide to use object based classification methods (meanshift segmentation), it’s important to understand what kind of land cover transitions you will ‘filter out’ and mark as stable. A change agent that operates at a large spatial scale – such as plantations – will most likely be captured using the segmentation methods. What do you think about capturing small scale changes, such as growth of settlements, when segmenting the landscape?
Note about scales of change and minimum mapping units: 
It is important that the varying scales of change occurring on the landscape are taken into account. Different land cover types (and subsequent change of these types) are characterized by different minimum mapping units (i.e., the size of the objects required to capture the feature or phenomenon). While image resolution will always be a limitation you may still need to map features / phenomena within your projects at different scales. For example, in this online training course you are working with Landsat imagery and cannot capture features / phenomena smaller than 30 m. When you create segments, it is not possible to capture features / phenomena smaller than those segments. 
[image: Scale_agents_of_change]
The objects of interest may vary in size depending on what you are trying to capture. For example, new development of built-up lands will likely occur at a very fine scale, while transition from natural forest to cleared land may occur at a much larger spatial scale. The goal is to preserve as many scales of features / change phenomena as possible.


[bookmark: _Toc508631753][bookmark: _Toc508632672][bookmark: _Toc508632694][bookmark: _Toc508632734][bookmark: _Toc428784175][bookmark: _Toc428784353][bookmark: _Toc437437280][bookmark: _Toc505765511]Module 3: Accuracy Assessment and Using Collect Earth Online
In this module, the user be introduced to accuracy assessments using Collect Earth Online (CEO) and error matrices. Collect Earth Online is a free, open-source, and user-friendly tool for land monitoring. It is completely web-based and no desktop installation is required. CEO offers simultaneous, cloud-supported data entry by multiple users. It enables crowd-source visual interpretations of satellite imagery, such as Digital Globe and Bing Maps, user-specified WMS and WMTS, and a variety of Earth-observation data sets from Google Earth Engine. In these exercises, the user will calculate measures of user’s accuracy, producer’s accuracy, and overall accuracy (with both raw measures and area estimates) in Excel using error matrices.  
[bookmark: _Toc508631579][bookmark: _Toc508632695][bookmark: _Toc508632735]Exercise 6: Accuracy Assessment – 2008 land cover map
[bookmark: _Toc508632673]Introduction
In this Module you will select a sample of reference observations from the study area with the aim of estimating accuracy of the land cover classification from Exercise 4. 
[bookmark: _Toc508632674]Objectives
· Generate a stratified random sample.
· Learn about response designs and practice generating reference data from a combination of remotely sensed data sources including the cloud free composite and an archive of high resolution aerial imagery available in Google Earth.
· Analyze the agreement between the classified image output, your 2008 land cover change map, and the reference data to estimate the accuracy of your classification product.
1. [bookmark: _Toc505765512][bookmark: _Toc505765542]Project Set up
Open a QGIS project
Start QGIS by clicking on the QGIS shortcut on your desktop  
Load the land cover and 2008-2010 cloud free composite data
Click on the Add Raster Layer icon. 
Navigate to the C:\Data\Images\imagery_subset folder.
Select the 2008_LC.tif and 2008_sub_9band.tif rasters. You can hold down the Ctrl key while selecting the rasters with your mouse to select both.
Adjust display settings
Right click on the 2008_LC.tif layer in the Layers Panel. Go to Properties > Style to change the name and color of the classes. 
Render type: Singleband pseudocolor
At the bottom of the Band Rendering box:
Mode: Equal interval
Classes: the number of land cover categories you included in your classification scheme  - I had four (forest, water, fallow/other, ag)
Select Classify
Now you can double click on any of the class/value rows in the table, you can double-click to edit the labels and the colors. 
Edit the labels to be text values – e.g., change ‘1’ to ‘forest’, etc.
Double click on each color swatch to change it to a color that matches land cover expectations (e.g., water is usually set to a blue display, etc).
Select OK to apply the updated settings to view your classification.
Right click on the 2008_sub_9band.tif layer in the Layers panel. Go to Properties > Style.
Set Render type to Multiband color 
Red band to Band 06 
Green band to Band 04
Blue band to Band 03 
Accuracy to Estimate
Click Load in the Load min/max values section. 
Then click OK to save the changes.
[bookmark: _Toc505765513][bookmark: _Toc505765543]Sample Design
The sampling design is the protocol for selecting the subset of spatial units (e.g., pixels or segments) that will form the basis of the analysis of area and accuracy. It is recommended that the sampling design is a probability sampling design, which incorporates randomization in the selection protocol and is defined in terms of inclusion probabilities, such that the inclusion probability is known and greater than zero for each unit in the sample. Multiple probability sampling designs are applicable, the most commonly used being simple random, stratified random, systematic and clustered. When choosing a design, three main decisions are: (1) whether to use clusters; (2) whether to use strata; and (3) whether to use a systematic or simple random protocol.
The primary motivation for cluster sampling is to reduce the cost of data collection – for example, if the map is large and high resolution data need to be collected for each unit in the sample, a clustered design will allow for collection only for the primary sampling units and not for the entire population (cluster designs as defined in this text include 2-stage designs). However, using clusters is recommended only if it warrants cost savings or practical advantages, because it results in a more complex analysis and the potential correlation between samples within a cluster increases bias. Using strata is helps when land cover change represents a small proportion of the total map - if not stratifying the sample, a very large sample might be required to ensure that change areas get sampled. A stratified design is usually a good choice, especially if the aim is to estimate land cover change. 
The change map we will be analyzing from Exercise 5 has 8 classes, but the methods we use are - they can be applied to any thematic map regardless of how the map was made, what classes we use, or how many classes exist. Because the aim is to estimate the area of forest change, it is recommended that you use the map classes as strata. This will ensure that a sufficient sample size is allocated to the change classes for estimation. 
After settling on a sampling design – stratified random in this case – you will need to determine the total sample size and allocation of the sample to strata. For this exercise, you will just focus on the basics of how to conduct an accuracy assessment so you will use a total of 40 plots. 
	
	Forest
	Water
	Fallow/Other
	Ag

	
	10
	10
	10
	10


Note: This is not a robust sample design, but rather a simplified sample design for the purpose of learning about how to conduct an accuracy assessment. 
4. Select Sample
Next the sample needs to be selected. This can be done in several ways, but many software lack good support for selecting a sample. Therefore, you will use a program written by Earth and Environment scientists at Boston University.
QGIS does not have built-in tools for drawing samples so you need to make use of two Python scripts, sample_map.py and docopt.py, in the folder you’ve copied from the USB to the C drive (C:\QGIS_Scripts). 
First you will open the OSGeo4W command line shell. Go to your desktop and double-click the OSGeo4W.bat – Shortcut. 
Once the shell opens, navigate to the directory where the land cover classification output is stored.
cd C:\Data\Images\imagery_subset
Type the command below. This will open a dialog with descriptions about the available sample settings. 
python C:\QGIS_Scripts\sample_map.py -h 
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To select a stratified random sample, type: 
python C:\QGIS_Scripts\sample_map.py -v --mask 0 --size 40 --allocation "10 10 10 10" --vector sample.shp stratified C:\Data\Images\imagery_subset\2008_LC.tif
Note: when it’s done running, you will see a screen like the one on the next page which indicates the sample has been created. This has now created a shapefile called sample.shp that contains the stratified random sample with 10 points per strata based on the 2008_LC.tif land cover map you created in the previous exercise.  Note you might also get a popup that python.exe has stopped working. As long as the text indicates that the sampling is complete, everything ran correctly. Close the window.
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Thought question: If you wanted to create 10 points per strata using another land cover classification output, what would you need to modify in the call?
Load the sample into the QGIS project
Return to QGIS. Click the Add Vector Layer icon. Browse to the working directory (C:\Data\Images\imagery_subset) and select the shapefile you just created, called sample.shp to see where the points were located. 
Note, you likely won’t see the plots in the map, because the plot area is so small. You can select a row from the attribute table and zoom to the selected feature to zoom into where a plot is located.
[bookmark: _Toc505765514][bookmark: _Toc505765544]Response Design
Once you design the sample and a stratified random sample has been created, you will need to interpret the land cover at these locations using a suitable source of reference data. Then you will need to decide if the map and reference observations agree. This step is referred to as the response design. 
First, you need to identify the reference data sources. Ideally, you would have plots revisited in the field. However, this is rarely attainable given limited resources. An alternative is to collect reference observations through careful examination of the sample units using high resolution satellite data, or moderate resolution if high resolution is not available. The more data you have at your disposal the better. If you have no additional data you can use the Landsat data for collecting reference observations, as long as the process to collect the reference data is more accurate than the process used to create the map being evaluated. Careful manual examination can be regarded as being a more accurate process than automated classification. In addition to Landsat data, you can use whatever data are available in Collect Earth, Google Earth™, and other imagery services. The accuracy estimates are based on the sample, therefore it is important that the labels are correct. It is recommended that three interpreters examine each unit independently.
A. Create CSV for upload to Collect Earth Online
1. For this project, we will use the shapefile we created in Part 2 A of this exercise. First, we need to convert the shapefile into a csv file for upload to Collect Earth Online.
2. Open QGIS and load your shapefile from Part 2 A, called sample.shp, which is saved under C:\Data\Images\imagery_subset.
Collect Earth Online uses a different coordinate system than we used previously for the composite images while working in QGIS. We need to first load our csv file into QGIS using the coordinate system we used when generating the sample points (EPSG:32648 WGS 84). 
3. Your document’s coordinate system is still set to EPSG:32648 in the bottom of the QGIS window.
[image: ]
Click Settings > Options > CRS and choose WGS84 EPSG:4326. Close and open QGIS to activate these changes.
To the right of the Always start new projects with following CRS dropdown menu, click the Select CRS button.
Type 4326 into the Filter bar, and then double-click on the Geographic Coordinate Systems item that reads EPSG:4326.
Click OK.
Save your project.
Close and reopen QGIS.
The CRS listed in the bottom right of your QGIS screen should now read EPSG:4326.
4. Right-click on sample.shp and click Save as. In the pop-up window, choose as File name ‘reprojected_sample‘ and select in the CRS field ‘EPSG:4326’. Click OK. A new layer called reprojected_sample will appear in the layers panel.
i. Click on the menu on Vector > Geometry Tools > Polygon centroids.
ii. The Input layer is your reprojected_sample [EPSG:4326]. In the Centroid fields, type ‘Centroids’. 
iii. Check Open output file after running algorithm. Click Run.
5. Right-click in the Layers Panel on the new Centroids layer and select Open Attribute Table. 
6. Click the Open Field Calculator button.
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i. In the pop-up window, check the Create a new field box. For output field name, type ‘latitude’. For the Output field type, choose Decimal number (real). Set Output field length to 10 and the precision (number of decimal places) to 7. 
ii. Type $y into the Expression tab field. Click ok.
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7. A new column ‘latitude’ with geographic coordinates for your sample plots is created in the attribute table. 
8. Repeat Step 6 (Field Calculator) for creating the new column called ‘longitude’. Write‘$x into the expression field. Close the attribute table.
9. Right-click on the Centroids layer and click Save as. In the Format dropdown menu, choose Comma Separated Value [CSV]. Browse to C:\Data and type as file name ‘upload_CEO’. Click Save. Click OK.
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10. Open the csv-file in your spreadsheet program of choice. The first column contains now the longitude coordinates and the second column the latitude coordinates. Now will be able to upload your csv-file with your sample points to Collect Earth Online under PLOT DESIGN > Upload CSV.
B. Setting up your account in Collect Earth Online
1. Go to http://collect.earth/home and click on the upper right panel on Login/Register. 
2. If you do not have an account yet, click on Register a new account and follow the instructions. 
3. Login with your email and password.
C. Start Collect Earth Online Project Setup
1. For setting up your project, go to your institution.  For this exercise, please select the Cambodia Change Detection institution – select it by pressing the (i) button to the right.
Note: In the future, if your institution is not yet represented in the system, you can create a new one. Learn how in the Collect Earth Online Manual, which you can find by going to the CEO Homepage, clicking Support, and then downloading the manual. 
2. Click Request Membership – you will be added to the institution.
3. Click Create New Project.
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4. This brings you to the Project Dashboard. 
5. Under Project Info, enter the project’s name and description. Note: it may be useful to include your name in the Project Info: Name field so that it doesn’t get confused with other participants’ projects.
6. In order to select your PROJECT AOI manually, click into the map window. Zoom in/out using the scroll wheel of your mouse, or the + and – boxes in the map window, to locate your area of interest. You can pan the map by clicking on it and dragging the map window. 
7. Once your area of interest is centered in the map window, hold the CRTL-key down and draw a box while keeping the left mouse key pressed down. The coordinate boxes will populate with coordinates once the box is drawn and you let your mouse key go.
8. Select your Project Imagery under Basemap Source in the dropdown menu. The map view will display the current selection. For this example, select DigitalGlobeWMSImagery and then 2016 for the Imagery Year and Accuracy Profile for the stacking profile.
Stacking Profile Options: These options set the criteria for selecting which image to display from all available imagery within the selected date range for any given plot location.
Accuracy_Profile: This profile returns high resolution features including those acquired using cameras mounted underneath aircraft and sub-meter satellite imagery.
Cloud_Cover_Profile: This profile returns visible light features (color and panchromatic) with the lowest cloud cover on top.
Global_Currency_Profile: This profile sorts all features (including infrared) chronologically, placing those features acquired most recently on top regardless of any other attribute.
MyDG_Color_Consumer_Profile: This profile is intended to give users the aesthetically best color experience. It provides only visible light color imagery.
9. PLOT DESIGN specifies the type and number of sample plots. 
i. Spatial Distribution defines the distribution of the sample points. There are three options: simple random, gridded, or uploading your own csv file specifying plot locations. 
(i) When selecting Random, you will then select the number of samples per plot. 
(ii) If you select Gridded, you will then need to supply the plot spacing parameter (in meters). 
ii. For this project, choose the radio button next to Upload CSV.
(i) Click on the Upload CSV text. 
(ii) Navigate to where you have saved your CVS file (C:\Data\upload_CEO.csv).
(iii) Select Open.
iii. Plot shape can be set as a Circle or a Square. You can choose the plot radius (for a circle) or the plot width (for a square). For this tutorial, choose Square with a radius of 30 meters for this project, which corresponds to the size of a Landsat pixel.
10. The SAMPLE DESIGN options allow you to specify the spatial distribution of your samples in each plot. 
i. If you choose Random, you can define the sample numbers per plot. 
ii. When choosing Gridded, you can specify the sample resolution (in meters). 
iii. Now, click on the text that reads Upload CSV in the PLOT DESIGN section (do not click the radio button, click the text). 
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11. PROJECT VISIBILITY sets the privacy level. For this example, choose Public.
i. Public: All users can see and edit your project.
ii. Private: Group Admins can see and edit your project.
iii. Institution: Group Members of your institution can see and edit your project.
iv. Invitation: Only invited users can see and edit your project.
D. Create your classification scheme
0. Name your classification scheme. Type “Sample Classes” into the box next to Add Sample Value Group, and then click the Add Sample Value Group button.
Add each class name. 
Type Forest into the box next to the plus sign.
Click on Color to choose a unique color for each label.
You can also add a reference image, but we will be skipping this step – to do so in the future, click on the Choose File button.
Click the + button to add the class.
Repeat for each class name present in your classification (e.g., water, fallow/other, and ag).
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A finished sample class will appear in the list. You can remove it again by clicking the minus button. After you enter your last sample class, you still need to click the Plus button once more to save the final sample class (picture below). 
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When your sample values are finished, click on CREATE PROJECT. A pop-up window will ask ‘Do you REALLY want to create this project?’ Click OK. 
Now the map box will automatically zoom into your region of interest and draws a red box corresponding to the extent of your sample plots. The field for number of plots is also filled automatically and reads now ‘40’.
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E. Create a new widget 
1. A GEO-DASH can show additional information, such as NDVI time series, to help with classification. Click CONFIGURE GEO-DASH. Tip: You can also edit the GEO-DASH later when analyzing plots.
2. The GEO-DASH will open in a new tab in your browser. Click on New Widget.
3. In the first dropdown menu, select NDVI Graph.
4. Enter a descriptive title in the Title field, like ‘NDVI’.
5. In the Select Graph Date Range you would like field, use the YYY-MM-DD format or click inside the boxes and use the calendar to select dates. Use the date range 2008-01-01 to 2010-12-31.
6. Columns: A number up to 12 specifies how wide the widget will be. 4 will create a square, larger numbers a rectangle. If not filled out, the widget will be a square. For now, choose 8.
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i. For editing or deleting you widget, click on the wheel icon.
ii. Repeat the same steps to create a widget for NWDI.
iii. After setting the NDVI widget up, click Create widget. To see the changes in your new widget, you need to open a plot in your project and activate the GEO-DASH window again. 
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F. Publish your project
1. Before working on your project, you need to publish it.
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2. Click the Publish Project button. 
3. A pop-up window will appear that asks ‘Do you REALLY want to publish this project?’ Click OK. 
G. Add and manage users
1. If you don’t have users to add to your project, skip to part H.
2. The administrator of an institution can add and manage its users. Go to Home and select your institution. 
3. To add a user, enter the user’s email address in the Users tab and click ADD USER.
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4. A pop-up window notifies you that the user [email address] has been given the role ‘member’. Click OK. 
5. The user’s email address appears now in the Users panel. Using the drop-down menu, the role can be changed from Member to Admin or Remove to remove the user from the list. 
H. Analyze your plots
1. Go back to the Home page. Click on your institution, then click under the projects panel on your project’s name.
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2. To start collecting information about your plots, click on NEXT PLOT. 
3. The GEO-DASH window opens in a new tab. New widgets can be set up as described in Part 3, step E of this exercise: Create A New Widget. Note: if you do not see the GEO-DASH window pop-up, you will have to allow pop-ups in your browser.
4. Each sample point within a plot is identified by a small red circle. 
5. Change the IMAGERY OPTIONS dropdown to Digital Globe, 2008-2010. This dataset represents the time period for imagery used to create your 2008 classification.
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6. You can zoom in and out using the + and - button in the map window, or simply by scrolling your mouse wheel.
7. Select your sample points. 
i. To select a single sample point, click on it with the left mouse key.
ii. To select several sample points, click on them while keeping the Shift key pressed down.
iii. To select all or a larger area of sample points, you can draw a rectangle to select them. Press the Ctrl-key and click in the map window and draw your rectangle.
8. If you need more detail about the area, zoom out or use the IMAGERY OPTIONS dropdown menu to flip to different datasets for context – make sure that you are making your interpretations based on the correct time period.
9. When your sample points are marked in blue, you can assign them a sample value by clicking on the suitable value in the legend to the left of the map window. In this example, we click on ‘Forest’. The sample points are then marked in the color of the value class.
[image: ]
[image: ]
10. When all sample points of your current plot are classified, click on SAVE ASSIGNMENTS. 
11. A pop-up window shows up stating that the assignment got saved to the database. Click OK. If CLICK ASSIGNMENTS is still shadowed in grey, not all sample points are classified yet.
12. The next plot for analysis shows up automatically.
13. If the background is completely black or gray as shown in the figure below, the resolution is too low for the automatically set zoom level, or the plot is in the ocean. Zoom out until you see the map to confirm whether the issue is imagery resolution or an oceanic plot. 
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14. If the resolution of a plot is too low to distinguish features and classify your points, click on FLAG PLOT AS BAD. A pop-up window appears informing you that the plot [number] has been flagged. Click OK. 
15. When you have classified all plots, a pop-up window shows up to inform you that all sample plots of your project are classified. 
16. The progress of the analysis is shown in the PROJECT STATS table in the top right corner.
i. Plots Assigned: number and percent of plots that have been analyzed.
ii. Plots Flagged: number and percent of plots that have been flagged as bad.
iii.  Plots Completed: number and percent of plots that have been analyzed or flagged as bad.
iv. Plots Total: The total number of plots of this project. 
Download and prep your data
A. Download your data
1. Under Project Management, click on DOWNLOAD PLOT DATA to download your points as a csv file. 
2. The csv file will download with this structure: 
i. PLOT_ID stands for the sample number. 
ii. CENTER_LON and CENTER_LAT are the geographic coordinates of the center of your sample, which has RADIUS_M. 
iii. FLAGGED will say FALSE for a sample where data was collected or not analyzed yet, while TRUE means the quality of the background map was too bad to label the samples (due to clouds or poor image resolution).
iv.  ANALYSIS will show a 1 for plots that are analyzed, and 0 stands for not analyzed. If more than one person assigned a label to a plot, this column will indicate the number of analysts that have assessed the plot.
v. SAMPLE_POINTS stand for the number of samples in each plot. 
vi. USER_ASSIGNMENTS is the unique (numeric) ID of the user that collected the information for any given plot.
vii. FOREST, WATER and OTHER columns indicate the fractional coverage of each value, or land cover label, per plot, listed as a percent.
B. Interpreting sample
1. Open the csv file you just downloaded in Excel or another spreadsheet program. 
Note: The steps below assign the land cover class using a 20% forest cover and water threshold. You can modify these instructions to match the land cover definitions you have selected for your project. You drafted these land cover class definitions in Exercise 4, Part 2. 
2. Add two new columns, call them reference and label.
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3. Refer to the land cover classes, their numeric values and classification from exercise 4 (Land Cover Classification) Part 3B “Digitize your regions of interest”. Make sure that your classification is reasonable based on Part 2A “Defining forest land cover”. 
Forest = 1
Water = 2
Fallow/Other = 3
Ag = 4
i. First we determine if a plot is forest or non-forest. Let’s take >20 % as forest for this project.
ii. If a plot is non-forest, check if it is >20% water, then we classify it as water.
iii. If a plot is non-forest and <20% water, we classify it as either fallow/other or ag for this example.
iv. If in this plot fallow/other > ag, the plot is fallow/other for this example
v. Else, it is ag.
4. To automate this classification, set up an if-statement in excel or your preferred spreadsheet software: 
i. Click on the first cell in your reference column and write in the function line (red box in the figure below) the following statement: 
=IF(J2>20,1, IF(K2>20, 2, IF((AND(L2>20, M2<20)),3,4))) 
Press enter. Fill your entire column by double-clicking on the bottom right hand corner of your green cell. The reference labels get filled.
Tip: If you want a different threshold than 20%, just change the ‘20’ in the statement to your threshold.
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ii. We still want to add the human readable names of the classes represented by the numeric values. Therefore, we want to add the corresponding word into the label column.
iii. Write the following if-statement into the function line and fill your column with it:
=IF(N2=1,"forest", IF(N2=2, "water", IF(N2=3,"fallow/other","ag")))
iv. Save your file as a csv file format.
C. Convert your csv file into a shapefile using QGIS
1. Open QGIS. Click on Layer, then click Add Layer. [image: ]
2. Click Add Delimited Text Layer.
3. Browse to your csv file in the window that appears under File Name.
i. Select under File Format csv (comma separated values). 
ii. Make sure that Geometry definition is set to Point coordinates, the X field is set to CENTER_LON, and Y field to CENTER_LAT. Click OK. 
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4. The Coordinate Reference System Selector window appears. 
Collect Earth Online uses a different coordinate system than we used previously for the composite images while working in QGIS. We need to first load our csv file into QGIS using the coordinate system from Collect Earth online (EPSG:4326 WGS 84). Then we will reproject it in a second step.
5. Type into the Filter field 4326. Under Coordinate reference systems of the world, click on WGS 84 EPSG:4326. Click OK.
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6. Now your points will appear in the map window and in the Layers Panel. 
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7. Right-click on your layer file in the Layers Panel and click Save As. 
i. The Save vector layer as… window opens. 
ii. Choose as Format ESRI Shapefile. 
iii. Click Browse and select your path as C:\Data\Images\imagery_subset. Enter a file name (here: sample_CEO). The file type ending “.shp” will be added automatically.
iv. Change the coordinate system to match our composite image. Click on the Select CRS button[image: ]
v. The Coordinate Reference System Selector window opens. Type into the Filter field “32648”. Click on “WGS 84 / UTM zone 48N EPSG:32648” and click OK.
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vi. Click OK. You can close QGIS again.
D. Construct the error matrix
Once the sample has been interpreted, the agreement between map and reference labels needs to be measured. The agreement is preferably expressed in the form of an error matrix, which is a simple cross-tabulation of the map labels against the reference labels for the sample units. The error matrix organizes the acquired sample data in a way that summarizes key results and quantifies accuracy and area. The main diagonal of the error matrix highlights correct classifications while the off-diagonal cells show omission and commission errors. The cell entries and marginal values of the error matrix are fundamental to both accuracy assessment and area estimation.
1. With each unit having a map label and a reference label you can construct an error matrix. This can be done in various ways but we recommend using a home-made script that executes in the terminal. 
2. Return to the OSGeo4W Shell and if it’s not still pointing to the imagery_subset folder, navigate to it (C:\Data\Images\imagery_subset).
3. In the Shell, type python, the full pathname to the crosstab python script, -v, -a, the name of the column in the sample shapefile with the reference data, the name of the classified raster, the name of the sample shapefile, and finally the name of the file that you will be generating. See the example below.
python C:\QGIS_Scripts\crosstab.py -v -a reference 2008_LC.tif sample_CEO.shp errormatrix.txt
Note: If you named the field something other than ‘reference’ when you added a new column previously in Part A, you will need to edit this line of code accordingly. It is case sensitive, so if you named the field ‘Reference’ update the casing accordingly.
i. This will create text file that contains the error matrix called “errormatrix.txt” in the imagery_subset folder.
Note: If the script gives you an error regarding varying input shapes, check to make sure your raster file has the same number of classes as the shapefile. If the edges of your map contain 0s, you do not have any 0 values in your shapefile, and 0 is not the no data value of your raster, the script will not work. 
To fix this create a new raster with 0 as the no data value by going to Raster -> Conversion -> Translate. For Input Layer select the classified raster, select a name for the Output file, and for No data put 0 (or whatever you want to declare the no data value).
Analysis
With an error matrix area estimation becomes straightforward. At the heart of the analysis is the implementation of an unbiased area estimator. Different estimators can be implemented, but with a sample stratified by discrete map classes, stratified estimation has proven useful. A stratified area estimator includes the error of omission but excludes the error of commission, and it is easily implemented using the data in the error matrix. Using the error matrix one can also estimate the accuracy of the map and the map classes.  Note that stratified estimation can be used with simple or systematic random samples too. 
E. Open the error matrix in a spreadsheet software
1. Open Microsoft Excel.
2. In Excel, go to File > Open > browse. 
i. Change the type from All Excel Files (*.xlsx…) to All Files (*.*). 
ii. Open the text file created in previous steps. 
iii. Choose Delimited. Click Next.
iv. Select Comma as the Delimiter. Click Next.
v. Then Finish.
vi. The screen should like below:
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3. First, rename the columns and rows so that they are more intuitive to work with. In this example. Class 1 is forest, class 2 is water, and class 3 is other. Rename the table headers accordingly. See example below.
4. Save the file as an Excel Spreadsheet
i. Click File > Save As
ii. Change type From Text (Tab delimited) (*.txt) to Excel Workbook (*.xlsx)
iii. Click Save
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4. Below the error matrix output, invert the matrix
5. Below the sample error matrix information – duplicate the matrix, but invert the information (such that the reference information is stored as columns, and the map information is stored as rows).
i. Starting with cell A7, click and drag your mouse down to cell E11.
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ii. In the function bar, type =transpose(A1:E5) and hold down the Ctrl + Shift + Enter keys.
iii. You will see that cells A7:E11 are now populated with the information from your error matrix, but the rows and columns have been transposed.
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Note: You may notice curly brackets in the screen capture above – these were populated automatically after pressing the Ctrl + Shift + Enter keys. Do not type these in yourself.
F. Adding labels
1. Add Map Total as a column label on the right hand side of the lower matrix.
2. Add Reference Total as a row header at the bottom of the map labels.
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G. Calculate reference and map sums
1. In the cell below Map Total (E8), total the number of instances where the forest category was mapped by entering the following:
=sum(B8:E8)
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2. Repeat for the other mapped land cover classes by highlighting cell E8, clicking the lower right-hand corner of the cell, and dragging it down to cell E11.
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3. Repeat the summing process for the Reference Total counts (see example below).
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H. Calculate the Accuracy of the map
Finally, you can estimate the accuracy of the map. Three different accuracy measures are of interest: 
· overall accuracy which is simply the sum of the diagonals in the error matrix of estimated area proportions; 
· user’s accuracy which for a map category i is given by  and 
· producer’s accuracy for map category j given by  where  and   are the row and columns totals respectively. 
1. To the right of the Map Total label, add User’s Accuracy. 
i. In the cell below the Reference Total label, add Producer’s Accuracy. 
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Note: We’ve also shaded the diagonal green – this makes it easier to see what we predicted correctly in our map. It also makes it easier to identify which cell values to use when calculating User’s and Producer’s Accuracies.
3. To calculate the User’s Accuracy, you will divide the agreement (the diagonal along the matrix where, for example, forest reference and forest map intersect) by the Map Total.
i. In cell G8, type in the following:
=B8/F8
ii. This equation will calculate the total number of forest samples that were mapped correctly (in this example, there are 9 correctly mapped samples) and divide by the total number of forest samples in the map (you placed 10 samples within each class, so there are a total of 10 forest samples).
iii. Repeat this process for each mapped category.
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Note: this means that the user’s accuracy for the forest land cover is 90%; so the error of commission is 10%. The user’s accuracy for the water land cover is 0%; so the error of commission is 100% - this means that according to these reference data, the map creator did not map any of the water class correctly.
What is the user’s accuracy and error of commission for the fallow/other class in this example (5/10)?
4. To calculate the Producer’s Accuracy, you will divide the agreement (the diagonal along the matrix where, for example, forest reference and forest map intersect) by the Reference Total. In the image below, the agreement cells are highlighted in green. 
i. In cell B13, type in the following:
=B8/B12
ii. This equation will calculate the total number of forest samples that were mapped correctly (in this example, there are 5 correctly mapped samples) and divide by the total number of forest samples in the reference data (in this example, 8 of the total samples were interpreted as forest).
iii. Repeat this process for each mapped category.
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Note: this means that the producer’s accuracy for the forest land cover is 50%; so the error of omission is 50% - that’s kind of high! The producer’s accuracy for the water land cover is 0%; so the error of omission is 100% - this means that all of the water samples were omitted from the map classification.
What is the producer’s accuracy and error of omission for the ag class in this example (5/12)?
I. Calculate Overall Accuracy
2. To calculate the Overall Accuracy, first you need to determine the area of land that each of the strata cover. You will determine the areas of each map category using a gdal tool called from the OSGeo4W command line shell. Return to the command line shell and type in the following:
gdalinfo -hist 2008_LC.tif 
Note: The return looks a little messy. The information you are interested in is the summary below the bucket information line (highlighted in red in the image below). It gives you the count of the number of pixels in each ‘histogram bucket’. In this example, the histogram is broken up into 4 buckets – starting at 0.625 to 4.375. This indicates that there are:
- 89,170 pixels with a value between 0.625 and 1.5625 (forest land cover); 
- 52,741 pixels with a raster value between 1.5625 and 2.5 (water land cover); 
- 17,988 pixels with a value between 2.5 and 3.4375 (fallow/other land cover); 
- 14,737 pixels with a value between 3.4375 and 4.375 (ag land cover)
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3. In the column to the right of the User’s Accuracy, type in the column header Pixels. 
4. Use the information from the gdalinfo call in the OSGeo4W command line shell to update the pixel count of each land cover category.
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5. To the right of the Pixels column header, type in Weights. 
6. Now calculate the weights by dividing the pixel value by the sum of pixel counts for all three land cover categories.
=H8/SUM($H$8:$H$11)
7. Copy and paste the equation for the other two land cover categories.
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Next you will calculate the overall accuracy after taking into account the area weights. You will learn more about the equation, specifically the use of weighting your overall estimates by area, in Exercise 7 
8. Underneath your estimate of producer’s accuracy, type Overall Accuracy, weighted by area. 
9. In the cell to the right of the new label, type in the following equation.
=(I8*B8/F8)+(I9*C9/F9)+(I10*D10/F10)+(I11*E11/F11)
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Note: In this example, the overall accuracy is fairly low – it’s 55.3%. This means that for any given pixel there is a 55.3% chance that it has been mapped correctly. Or you could reverse the focus to the likelihood of error – in which case for any given pixel there is a 44.7% chance that it is mapped incorrectly.

[bookmark: _Toc437437283][bookmark: _Toc508631580][bookmark: _Toc508632696][bookmark: _Toc508632736]Exercise 7: Accuracy Assessment – 2008-2013 change classification
[bookmark: _Toc508632675]Introduction
In this exercise you will select a sample of reference observations of the study area with the aim of estimating the area of forest change. You will also use the sample for estimating accuracy of the map and map classes. If stratifying, any map can be used for strata, but these instructions will refer to the land cover change map that was constructed in Exercise 5: Change Detection. The basic idea here is that we assume that the mapped areas of land cover (or change in land cover) are biased because of image classification errors. These errors are identified by comparing the map to a sample of reference observations. Area estimates and accuracy are then inferred by analyzing the sample. This process includes three main steps: 1) designing and selecting the sample; 2) response design: interpreting the sample and identifying agreement between the reference and map observations; and 3) analyzing the sample. 
[bookmark: _Toc508632676]Objectives
· Learn about the design and selection of a sample.
· Learn about response designs and practice generating reference data from a combination of remotely sensed data sources including the cloud free composite and an archive of high resolution aerial imagery available in Google Earth.
· Estimate the change area and accuracy of the change map.
1. [bookmark: _Toc505766107]Project Set up
Open a QGIS project
Start QGIS by clicking on the QGIS shortcut on your desktop  
Load the change classification raster and two date cloud free composite data sets
Click on the Add Raster Layer icon. 
Navigate to the C:\Data\Images\imagery_subset folder.
Select the LC_08_13_NBR.tif, 2008_sub_9band.tif, and 2013_sub_9band.tif rasters. You can hold down the Ctrl key while selecting the rasters with your mouse to select them all.
Adjust display settings
Right click the LC_08_13_NBR.tif layer in the Layers panel > Properties > Style to change the name and color of the classes. Refer to previous exercises for instructions on how to do this. 
Adjust the display of the 2008_Sub_9band.tif and the 2013_Sub_9band.tif images. Save your project as Area_estimate.qgs.
[bookmark: _Toc505766108]Sample Design
Update the area, measured in pixels, of each land cover class in the classified map
Determine the areas of each map category using a gdal tool called from the OSGeo4W Shell. Return to the Shell and type in the following:
gdalinfo -hist C:\Data\Images\imagery_subset\LC_08_13_NBR.tif 
Note: The return looks a little messy. The information you are interested in is the summary below the bucket information line (highlighted in red in the image below). It gives you the count of the number of pixels in each ‘histogram bucket’. In this example, the histogram is broken up into 256 buckets, one for each value in an 8-bit raster file. This histogram indicates that there are:
- 944,898 pixels with a value of 1 (stable forest land cover); 
- 6,353 pixels with a raster value of 2 (stable water land cover); 
- 898,674 pixels with a value of 3 (stable fallow/other land cover); 
- 85,043 pixels with a value of 4 (stable ag land cover);
- 1,284,177 pixels with a value of 5 (forest loss land cover);
- 936,713 pixels with a value of 6 (forest gain land cover);
- 27,174 pixels with a value of 7 (fallow/other to ag land cover); and
- 397,005 pixels with a value of 8 (ag to fallow/other land cover). 
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0. Below, you will find an example table and a table for you to fill in. In the second table, fill in the number of pixels of each map class in your output. Note: If it’s easier, construct this table in Excel.
Calculate the Total number of pixels by adding together the pixel counts of all land cover categories. Fill this into the final column, Total.
Calculate the percent coverage (Wi) by dividing the strata total by the sum of all strata. Fill these values into the third row of the table. 
Example Table: 
	
	Stable Forest
	Stable Water
	Stable Fallow/ Other
	Stable Ag
	Forest Loss
	Forest Loss
	Fallow/ Other to Ag
	Ag to Fallow/ Other
	Total

	Area
	944898
	6353
	898674
	85043
	1284177
	936713
	27174
	397005
	4480037

	Wi
	944898/4480037 = 0.2063
	0.0014
	0.1962
	0.0186
	0.2804
	0.2045
	0.0059
	0.0867
	


Your Table:
	
	Stable Forest
	Stable Water
	Stable Fallow/ Other
	Stable Ag
	Forest Loss
	Forest Loss
	Fallow/ Other to Ag
	Ag to Fallow/ Other
	Total

	Area
	
	
	
	
	
	
	
	
	

	Wi
	
	
	
	
	
	
	
	
	


How to Determine Your Sample Size:
To determine the sample size for a stratified random sample, you can use Eq. 5.25 in Cochran (1977): 
 is the stratum weight and 
 is the standard error for stratum i; estimated as , 
 is the proportion of forest loss in stratum i. 
 is the target standard error of the forest loss estimate. 
If you assume one error of omission of forest loss in non-forest and forest per 100 units and a user’s accuracy of 0.8 and a target standard error, of the forest loss estimate of 0.5% (i.e., a confidence interval of 1%); you get the following information for determining the sample size:
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Now plug in the numbers from the table into the equation and solve for n:




The second step is to determine how to allocate these units to strata. Good practices stipulate that these are allocated proportionately based on area, with at least 50, 75, or 100 units are allocated to the all classes. In this water and forest loss have fewer than 50 samples, so increase these to 50, resulting in final sample size of 567.
	
	Water
	Forest
	Other
	Forest loss
	Forest gain

	
	532 * 0.051=
27
	532 * 0.501=
267
	532 * 0.128=
68
	532 * 0.071=
38
	532 * 0.249=
132

	
	Since 27< 50, increase sample size: 
50
	
267

	
68

	Since 38< 50, increase sample size: 50
	
132



Note: this is just an example and users need to specify their own target errors and expected accuracy and omission errors.
5. Select Sample
For this exercise, you are going to keep things simple. Use 10 sample reference plots per land cover class strata. Now you will select the sample. 
Open the OSGeo4W command line shell. Go to your desktop and double-click the OSGeo4W.bat – Shortcut. 
Once the shell opens, navigate to the directory where the land cover classification output is stored.
cd C:\Data\Images\imagery_subset
To select a stratified random sample, type: 
python C:\QGIS_Scripts\sample_map.py -v --mask 0 --size 80 --allocation "10 10 10 10 10 10 10 10" --vector change_sample.shp stratified LC_08_13_NBR.tif


Note: when it’s done running, you will see a screen like this which indicates the sampling has completed. This has now created a shapefile called change_sample.shp that contains the stratified random sample with 10 points per strata based on the LC_08_13_NBR.tif raster you generated in Exercise 9.
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[bookmark: _Toc505766109]Response Design
A. Create CSV for upload to Collect Earth Online
1. For this project, we will use the shapefile we created in Part 2 of this exercise. First, we need to convert the shapefile into a csv file for upload to Collect Earth Online.
2. Open QGIS and load your shapefile from Part 2, called change_sample.shp, which is saved under C:\Data\Images\imagery_subset.
Collect Earth Online uses a different coordinate system than we used previously for the composite images while working in QGIS. We need to first load our csv file into QGIS using the coordinate system we used when generating the sample points (EPSG:32648 WGS 84). 
3. Your document’s coordinate system is still set to EPSG:32648 in the bottom of the QGIS window.
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Click Settings > Options > CRS and choose WGS84 EPSG:4326. Close and open QGIS to activate these changes.
To the right of the Always start new projects with following CRS dropdown menu, click the Select CRS button.
Type 4326 into the Filter bar, and then double-click on the Geographic Coordinate Systems item that reads EPSG:4326.
Click OK.
Save your project.
Close and reopen QGIS.
The CRS listed in the bottom right of your QGIS screen should now read EPSG:4326.
4. Right-click on change_sample.shp and click Save as. In the pop-up window, choose as File name ‘reprojected_change_sample‘ and select in the CRS field ‘EPSG:4326’. Click OK. A new layer called reprojected_change_sample will appear in the layers panel.
i. Click on the menu on Vector > Geometry Tools > Polygon centroids.
ii. The Input layer is your reprojected_change_sample [EPSG:4326]. In the Centroid fields, type ‘Centroids’. 
iii. Check Open output file after running algorithm. Click Run.
5. Right-click in the Layers Panel on the new Centroids layer and select Open Attribute Table. 
6. Click the Open Field Calculator button.
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i. In the pop-up window, check the Create a new field box. For output field name, type ‘latitude’. For the Output field type, choose Decimal number (real). Set Output field length to 10 and the precision (number of decimal places) to 7. 
ii. Type ‘$y’ into the Expression tab field. Click ok.
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7. A new column ‘latitude’ with geographic coordinates for your sample plots is created in the attribute table. 
8. Repeat Step 6 (Field Calculator) for creating the new column called ‘longitude’. Write ‘$x’ into the expression field. Close the attribute table.
9. Right-click on the Centroids layer and click Save as. In the Format dropdown menu, choose Comma Separated Value [CSV]. Browse to C:\Data and type as file name ‘upload_change_CEO’. Click Save. Click OK.
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10. Open the csv-file in your spreadsheet program of choice. The first column contains now the longitude coordinates and the second column the latitude coordinates. Now will be able to upload your csv-file with your sample points to Collect Earth Online under PLOT DESIGN > Upload CSV.
Create a new Collect Earth Online project
If you need a hint on how to do this refer to the instructions in Exercise 6, Part 3C. These will show you how to set up a new project in Collect Earth Online. 
Choose the same Spatial Distribution settings as you did in the first accuracy assessment (Exercise 6, Part 3C). Refer to the image below.
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Create your classification scheme
Set up your classification scheme in your new project. Make sure your labels match those that you’ve been working with in your change map, described in this Exercise 5, Part 5D. They are also listed in the table below. 
	Land Cover Class
	Numeric Value

	Forest (stable)
	1

	Water 
	2

	Fallow/Other
	3

	Ag
	4

	Forest Loss
	5

	Forest Gain
	6

	Fallow/Other to Ag
	7

	Ag to Fallow/Other
	8


Set up a GEO-DASH widget for NDVI and NDWI
Refer to Exercise 6, Part 3E Create a new widget to set up a new widget in the GEO-DASH window. 
Set up a new widget for both NDVI and NDWI covering the same time span as the change detection analysis in this exercise. Choose 2008-01-01 as start date and 2013-12-31 as stop date. 
Click Publish to publish your project. Click OK to confirm that you REALLY want to publish this project.
Analyze your plots
Next you will select each sample point within the plot and assign a land cover class. If needed, refer to Exercise 6, Part 3H to get a refresher on how to analyze and classify your sample points in Collect Earth Online. 
You will need to determine if there has been a forest cover change between 2008 and 2013. You can flip between the 2008-2010 imagery and the 2013-2015 imagery, and you can also refer to the NDVI plot in the GEO-dash window. For each plot, refer to the GEO-dash widget you created, which is open in the second tab of your browser window. The NDVI time series plot shows time on the x-axis and the NDVI value on the y-axis. You can click and drag in the plot area to zoom in. Click on the Reset Zoom field to return to the entire time series.
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Interpret the NDVI plot: You can compare the NDVI time series over time to detect changes in photosynthetic activity of vegetation. A higher NDVI value shows a larger difference between the red and NIR radiation, which signals photosynthetically active vegetation. A low NDVI value represents no or very low photosynthetic activity. Refer to the section ‘How does NDVI change over time’ in Exercise 5, Part 7A to see an example of how NDVI changes over time for a normal forest, the impact of fire and of beetles.
Note, if you observe a change in NDVI that indicates either forest gain or loss you should mark all sample points within the plot with this label. The resolution of Landsat data, the source of the time series graph, is the same as the plot size of this reference data collection effort.
If a sample plot is located in a forested area, check if the NDVI value is stable over time. If the NDVI is stable, mark the samples located over forest as Forest (stable). 
If the sample is located in a forest and the NDVI value declines over time, mark all points within the plot as Forest Loss.
If the sample plot is in a forested area and the NDVI values increases over time, mark all points within the plot as Forest Gain.
For sample plots located over water, classify them as Water. 
For sample plots that flip between fallow/other and ag, label them as either Fallow/Other to Ag or Ag to Fallow/Other.
Download your data
After you have analyzed the sample points in all plots, download your data as a csv file. You can refer to Module 6, Part 4 if you need hints on how to do this.
Assigning a thematic label to the plot based on the sample point classifications
Open the csv file you just downloaded in Excel, or your preferred spreadsheet program. Add two columns, name them reference and label. 
As described in Exercise 6, Part 4B we need to add a numeric value for the land cover class into the reference column. 
For this project, we have set the Forest threshold at 20% canopy cover. 
If a plot is non-forest and >20% water, we classify the plot as Water.
If a plot is non-forest and <20% water, we classify is as the dominant cover percentage.
If the NDVI charts indicates any change, over write these settings to represent a land cover change category (either forest loss of gain). Note, since the resolution of the data used to create the NDVI chart is coarser than the high resolution imagery any identified change within the plot will be counted as a plot change. 
This classification is automated with the following If-statement. 
=IF(J2>20,1,IF(K2>20,2,IF(L2>50,3,IF(AND(L2>M2,L2>N2,L2>O2,L2>P2,L2>Q2),3,IF(M2>50,4,IF(AND(M2>N2,M2>O2,M2>P2,M2>Q2),4,IF(N2>50,5,IF(AND(N2>O2,N2>P2,N2>Q2),5,IF(O2>50,6,IF(AND(O2>P2,O2>Q2),6,IF(P2>50,7,IF(P2>Q2,7,8))))))))))))
In order to add the human readable labels, use the following IF-statement.
=IF(R2=1,"Forest stable",IF(R2=2,"Water",IF(R2=3,"Fallow/Other",IF(R2=4,"Ag",IF(R2=5,"Forest Loss",IF(R2=6,"Forest Gain",IF(R2=7,"Fallow/Other to Ag",IF(R2=8,"Ag to Fallow/Other","unknown"))))))))
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Convert your csv file into a shapefile using QGIS
Refer to Exercise 6, Part 4C to get hints on how to upload your csv file into QGIS as a spatial data set. Remember to load the csv in with the coordinate reference system, WGS 84 / EPSG:4326. Then change the coordinate reference system to match that of your composite image, WGS 84 / UTM zone 48N EPSG:32648.
Save as a shapefile in your working directory, and give it a descriptive file name, such as C:\Data\Images\imagery_subset\sample_change_CEO.shp. 
Construct the error matrix
Once the sample has been interpreted, the agreement between map and reference labels needs to decided; this could potentially be a complicated task but in this case you are using the map classes as strata, which makes the decision straightforward. The agreement is preferably expressed in the form of an error matrix, which is a simple cross-tabulation of the map labels against the reference labels for the sample units. The error matrix organizes the acquired sample data in a way that summarizes key results and aids the quantification of accuracy and area. The main diagonal of the error matrix highlights correct classifications while the off-diagonal elements show omission and commission errors. The cell entries and marginal values of the error matrix are fundamental to both accuracy assessment and area estimation.
With each unit having a map label and a reference label you can construct an error matrix. This can be done in various ways but we recommend using a home-made script that executes in the terminal. 
Return to the OSGeo4W Shell and if it’s not still pointing to the working directory, navigate to where the sample shapefile and land cover raster (LC_08_13_NBR.tif) are located (C:\Data\Images\imagery_subset).
In the Shell, type python, the full pathname to the crosstab python script, -v, -a, the name of the column in the sample shapefile with the reference data, the name of the classified raster, the name of the sample shapefile, and finally the name of the file that you will be generating. See the example below.
python C:\QGIS_Scripts\crosstab.py -v -a reference LC_08_13_NBR.tif sample_change_CEO.shp Ch_errormatrix.txt
This will create text file that contains the error matrix called Ch_errormatrix.txt in the imagery_subset folder.
Note: If the script gives you an error regarding varying input shapes, check to make sure your raster file has the same number of classes as the shapefile. If the edges of your map contain 0s, you do not have any 0 values in your shapefile, and 0 is not the no data value of your raster, the script will not work. 
To fix this create a new raster with 0 as the no data value by going to Raster -> Conversion -> Translate. For Input Layer select the classified raster, select a name for the Output file, and for No data put 0 (or whatever you want to declare the no data value).
[bookmark: _Toc505766110]Analysis
Open the error matrix in a spreadsheet software
Open Microsoft Excel.
In Excel, go to File > Open > browse. 
Change the type from All Excel Files (*.xlsx…) to All Files (*.*). 
Open the text file created in previous steps. 
Choose Delimited. Click Next.
Select Comma as the Delimiter. Click Next.
Then Finish.
The screen should like below:
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Rename the columns and rows so that they are more intuitive to work with. In this example. Class 1 is forest, class 2 is water, class 3 is fallow/other, class 4 is ag…. Rename the table headers accordingly. See example below.
Save the file as an Excel Spreadsheet
Click File > Save As
Change type From Text (Tab delimited) (*.txt) to Excel Workbook (*.xlsx)
Click Save
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Below the error matrix output, invert the matrix
Below the sample error matrix information – duplicate the matrix, but invert the information (such that the reference information is stored as columns, and the map information is stored as rows).
Starting with cell A12, click and drag your mouse down to cell I20.
In the function bar, type in =transpose(A1:I9) and hold down the Ctrl + Shift + Enter keys.
You will see that cells A12:I20 are now populated with the information from your error matrix, but the rows and columns have been transposed.
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Add the following labels to the columns on the right hand side of the just copied table header: 
Map Total
Pixels
W_i
Add Reference Total as a row header at the bottom of the map labels.
You can also format the cell borders and fill to make it easier to read. I’ve highlighted the agreement cells on the diagonal in green.
Calculate reference and map sums
In the cell to the right of the Reference Total cell, total the number of instances where the forest category appears in the reference data by entering the following:
=sum(B13:B20)
Repeat for the other reference land cover classes.
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Repeat the summing process for the Map Total counts. This should result in 10 for each category, because we created 10 samples within each class.
Update the area, measured in pixels, of each land cover class in the classified map
Revisit the table with the area covered by each stratum from Part 2 of this Exercise. I’ve re-copied the example table below. 
	
	Stable Forest
	Stable Water
	Stable Fallow/ Other
	Stable Ag
	Forest Loss
	Forest Loss
	Fallow/ Other to Ag
	Ag to Fallow/ Other
	Total

	Area
	944898
	6353
	898674
	85043
	1284177
	936713
	27174
	397005
	4480037

	Wi
	944898/4480037 = 0.2063
	0.0014
	0.1962
	0.0186
	0.2804
	0.2045
	0.0059
	0.0867
	


1. Use this table to fill in the Pixels (count of pixels per stratum) and W_i columns in the spreadsheet. 
0. You can calculate the weights using the formula in the upper part of the image below as a template – or just write them in directly. 
0. Type the equal sign, move the cursor over to the pixel count cell on the same row, then type in sum(, highlight the three pixel count cells, then close the parenthesis. 
The dollar signs in the formula keep the cell constant as you copy and paste the formula into other cells.
Estimating area proportions
In this case, the sample is stratified and the number of sample units per stratum is disproportionate relative to the area of the stratum; it is therefore necessary to estimate the area proportions  for each cell in the error matrix rather than sample counts before proceeding with the analysis. 
The area proportions are estimated as:

Where: 
·  are the stratum weights (the area proportion of stratum i), 
·  is the sample count in cell i,j, and
·  is the total number of sample counts in map category i. 
Type Error matrix, estimates area proportions below the Inverted Error Matrix.
Copy the inverted matrix and paste (as values) below the Error matrix, estimates area proportions title. 
Delete the numbers inside the error matrix that you’ve just copied. See image below.
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In the first data cell in the Error matrix, estimates area proportions matrix, calculate (the spreadsheet expression should be similar to “=$L13*B13/$K13” without the quotation marks; see screenshot below).
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Then just populate the rest of the first row of the matrix by highlighting the first cell and then “grabbing” the little black square at the bottom right of the cell (mouse pointer turns into a plus sign) and drag to the end of the row. 
Then highlight the first row of the matrix and drag down to populate the entire matrix.
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Highlight all cells > right click > Format cells... >  
In the Number tab, set Category to Number with 4 decimals.  
Select OK.
Calculate Area Estimates
The error matrix you just created contains all of the information required for stratified estimation area! And estimators are now easily obtained as the column totals of the estimated area proportions. 
Calculate the row and columns totals by typing =sum(, then highlight the row or the column, then close the parentheses. 
To check if you got it right: each row total should mimic the Wi total for the same row.
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You have just calculated unbiased estimates of area! These are the column totals. 
Note: To express these in hectares, rather than proportions, multiply the column totals (cells B25 to F25) by the map size and the pixel size in hectares (302/1002). For example, an unbiased area estimate of the water class in hectares is calculated as “=B25*SUM($H$20:$H$24)*30^2/100^2”. 
Run the hectare conversion in two steps. 
In cell A35, type in Area [pixels]. In A36, type in Area [hectares]. In a 37, type in SE(Area).
First calculate the area, as a count of pixels, for all classes. Populate the cells on row 35 with the pixel count. In cell B35, type in =B34*$K$34. Populate the rest of the cells in this row with this equation by grabbing the bottom right corner of the cell and dragging it right.
Now convert the pixel count to area, expressed in hectares by multiplying the count by 900 (30m by 30 m, aka 302, is the size of the Landsat pixel). Then divide by 10,000 (1002 is the conversion factor to convert square meters to hectares). In cell B36, type =B35*30^2/100^2. 
Drag this expression from the current cell into the other cells in row 36 – make sure that the reference to the count cell reflects the appropriate land use. E.g., cell C36 should have the following expression =C35*30^2/100^2.
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Calculate Standard Errors of Area Estimates
The next step is to calculate the standard errors of the area estimates, which are given by the following equation for a stratified random sample:    

This can be tricky to get right in a spreadsheet! Calculate the standard errors in row 28. 
The standard error - - for the water map (class 1, the first column total) is calculated as: 
=SQRT(($L$26*B26-B26^2)/($J$13-1)+($L$27*B27-B27^2)/($J$14-1)+($L$28*B28-B28^2)/($J$15-1)+($L$29*B29-B29^2)/($J$16-1)+($L$30*B30-B30^2)/($J$17)+($L$31*B31-B31^2)/($J$18)+($L$32*B32-B32^2)/($J$19-1)+($L$33*B33-B33^2)/($J$20-1))
Then just click the plus sign at the lower right hand side of the cell and drag it across the row to complete the calculations for the other classes.
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Now, calculate the standard errors in pixels by multiplying by the total number of pixels for the entire map by the standard error for that class (for example, =B37*$K$34).
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Then calculate the standard errors in hectares by multiplying pixel standard error measure times the pixel-to-hectare conversion unit. The conversion unit in this example is 30^2/100^2. 
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95% confidence intervals are given by multiplying the standard errors by 1.96. 
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Estimating map accuracy
Finally, you can estimate the accuracy of the map. We are interested in three different accuracy measures: 
· overall accuracy: the sum of the diagonals in the error matrix of estimated area proportions; 
· user’s accuracy: for a map category i is given by  
· producer’s accuracy: for a map category j given by  where  and   are the row and columns totals respectively. 
In the example below, I calculated: 
user’s accuracy in row 44 (=B26/J26), 
producer’s accuracy in row 48 ( =B26/B34), and 
overall accuracy in row 50 (=sum(B26,C27,D28,E29,F30,G31,H32,I33)). 
This gives the final spreadsheet with area estimates in green cells and accuracies in blue cells:
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[bookmark: _Toc497983146][bookmark: _Toc508631581][bookmark: _Toc508632697][bookmark: _Toc508632737]Appendix 1: Landsat Composites
[bookmark: _Toc508632677]Methods and Earth Engine Algorithms
Remotely sensed inputs for development of map products come from a variety of sources.  Optical and thermal data are from Landsat 5 Thematic Mapper (TM), Landsat 7 Enhanced Thematic Mapper (ETM+), and Landsat 8 Operational Land Imager and Thermal Infrared Sensor (OLI/TIRS), processed to top-of-atmosphere (TOA) reflectance and brightness temperature.  These data have approximately 30 meters ground resolution, multiple bands spanning visible to thermal wavelengths, and approximately 16-day revisit time.  These data are hosted in the Earth Engine data archive.  
We applied additional processing to the Landsat data to remove clouds and cloud shadows. The user has three masking options on line 51 – the user can specify ‘fmask’ ‘cloudScoreTDOM’, or ‘hybrid’. 
Fmask is an algorithm (Zhu and Woodcock, 2012; Zhu and others, 2015) that uses TOA and Brightness Temperature to identify potential clouds over both land and water, and then the NIR band is used to identify potential shadows using a flood-fill transformation. The view angle of the sensor and the illumination angle at the time of data acquisition are then used to predict possible shadow locations, and it identifies objects with the closest proximity in the potential shadows layer. 
The Temporal Dark Outlier Mask (TDOM) algorithm (Housman et al 2015) that identifies pixels that are dark in the infrared bands but are found to not always be dark in past and/or future observations.  This is done by finding statistical outliers with respect to the sum of the infrared bands.  Next, dark pixels are identified by using the sum of the infrared bands (NIR, SWIR1, and SWIR2). Solar geometry is then used to predict where clouds shadows should be.  Since a cloud height model was not developed, a range of potential cloud heights (200m-5000m) was used.  Within these expected shadow areas, if the pixels are both dark and dark outliers, they are considered to be cloud shadows and excluded from further analysis. 
[bookmark: _c71g58w6utlu][bookmark: _jd19aia9eedh][bookmark: _Toc508632678]Seasonal Composites
We computed seasonal composites for each Landsat band and each spectral index by computing the median in each pixel of all unmasked values from the year.  To capture the important phenological patterns on the landscape we created three seasonal composites, including a median dry hot season (Julian Dates 60 - 120), a median dry cool season (Julian Dates 305 - 59), and a median rainy season (Julian Dates 121 - 305).  We created 17 sets of these composites spanning years 2000 to 2016.  The composites are inputs for creation of biophysical primitives as described below.
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Here is a complete list of the bands in our seasonal composites. The factor is the number that band was multiplied by before being cast to signed 16 bit integer. To get the original values, divide by the factor. 
	Band Name
	Description
	Other Names
	Factor

	blue
	blue
	--
	10000

	green
	green
	--
	10000

	red
	red
	--
	10000

	nir
	near infrared
	--
	10000

	swir1
	shortwave infrared 1
	--
	10000

	swir2
	shortwave infrared 2
	--
	10000

	p10NDVI
	Tenth (10th) percentile NDVI value
	--
	10000

	p50NDVI
	Median NDVI value
	--
	10000

	p90NDVI
	Ninetieth (90th) percentile NDVI value
	--
	10000

	pxlcount
	Number of Landsat pixels sampled to make composite at this pixel location
	--
	10000


 
[bookmark: _Toc508631582][bookmark: _Toc508632698][bookmark: _Toc508632738]Appendix 2: Preparing Seasonal Imagery with Google Earth Engine
[bookmark: _Toc508632681]Introduction
In this exercise, you will focus on acquiring and preparing data that represents seasonal changes of the spectral signature to use for the cropland classification. You will learn how to use GEE for preparing and downloading this data. 
Objectives
· Create two seasonal image data sets for the two time steps that you would like to map and measure landscape change.
· Export the two data sets to your desktop so that you can work with them in QGIS.

1. Exploring seasonal metrics in Earth Engine
Open Earth Engine 
In your Google Chrome web browser navigate to Google Earth Engine by clicking this link: https://code.earthengine.google.com/. 
Sign in if prompted.
If prompted, allow the EE Code Editor to access your Google Account.
Load the visualization script
In the scripts tab, expand the Reader section by clicking on it. Note, the numbers in the image may be different than the numbers on your screen, depending on how many script groups you belong to. 
[image: ]
In this Reader section, navigate to the scripts folder called users/KarisTenneson/CambodiaChangeDetection. 
Open the script called Ex4a_NDVI_Seasonality_ChartDisplay.
Click Run. 
Notice what happens in the map window and console tab: 
The seasonal spectral metrics, also called the harmonic trends, are displayed in the map window. In this case it is the phenology of vegetation seasonality based on NDVI, a vegetation greenness index. 
The color, or hue, in the map represents the timing of the green up. 
The pink-red areas have a vegetation green up in June, July, or August. 
The green areas in the map have a vegetation green up timed later in the year (September and October). 
Blue areas have a spring green up season (e.g., in March). Some water bodies have this seasonal trend – is this the timing of emergent aquatic vegetation, rice, or algae blooms?
The color intensity indicates the magnitude of change over the year. Areas with a large seasonal variation in NDVI (distinct green up and brown down periods) will have a lighter color. Areas with little variation in NDVI will appear very dark (almost black).
(optional) turn on the NDVI_RMSE layer in the map window. This layer is the root mean square error between the predicted and observed NDVI values. The lighter color represents close agreement. Darker values represent larger errors between predicted and observed values. 
Three time series charts appear in the Console tab. These charts display the trends, or time series, for NDVI at three points with different land uses and land covers. The location is indicated on the map by three pin markers (red, green, and blue). Blue points are observed values, the red markers are the fitted trendline (predicted observations).
The northernmost point, colored with the green pointer in the map window, is located in a forest patch. Notice the top chart in the Console tab is the chart created at this forest location. 
The amplitude (or height) of the wave is small, indicating that the greenness level stays fairly consistent throughout the year. 
The location has a high range of NDVI values, between 0.5 and 1. So this region is consistently green throughout the year.
The peak green up (maximum NDVI value) occurs in October.
The red marker is located in a cropland field in the western portion of our study region. This marker is associated with the middle chart. 
Look at how the blue values and red values are often mis-aligned. The two wave patterns do not match up. This indicates that the seasonal cycle in this location exhibits three green up phases each year (three crop cycles). To better match this pattern, we can add another cycle into the harmonic function. We will explore this later in the exercise.   
The amplitude (variation in NDVI values over time) is much higher in comparison to the forest point. This reflects the seasonal cycle of planting, growth, and harvest.
The blue marker in the southern section of the study area is located in a different crop type, the associated chart is the bottom one in the Console. 
The predictions (red points) and observations (blue points) are better aligned than the previous cropland example. This chart suggests this region has one green up season per year, in September and October.
Finally, the amplitude (the amount of variation in NDVI values) is low. This region stays fairly green all year round, similar to the forest example.
Generating seasonal data
Open the script to export data
0. In the scripts tab, expand the Reader section. 
0. Navigate to the scripts folder called users/KarisTenneson/CambodiaChangeDetection. 
0. Open the script called Ex4a_ExportLandsatAnnualHarmonics.
0. Click Run to see what the script does.
3. Three things happen that are very similar to the LandsatCompositeDownload from the previous exercise: 
0. Information has printed in the Console tab, 
[image: ]
0. New items have appeared in the Tasks tab, 
[image: ]
0. A study region outline has populated the map window. Additionally, new layers have been added to the legend. However, they have been set by default to not display. 
[image: ]
Zoom into an area of interest. Then hover over the Layers box to expand the list of available layers. There is one layer for each year specified in the script. Toggle one of the layers on to draw it in the map window. Note: rendering the image may take a couple seconds, the closer your zoom level the fast the image will draw.

[image: ]
3. Next you will learn how to modify this script to meet your project needs by adjusting some of the processing parameters.
6. Import the new study region, the shapefile you loaded into your Assets folder in a previous assignment
Return to the Assets tab. Hover over the name of the shapefile that you just loaded into your assets, e.g., Study_Area.
[image: ]
Three icons appear to the right of the Table name, Study_Area. Click on the arrow icon to import the vector data into your current script. 
Change the variable name from table to CambodiaStudyRegion. 
Hint: you need to click on the variable name, table. Then type a new name in its place.
6. Save the changes to the script
Click the arrow adjacent to the Save icon. Select Save as…
[image: ]
Save the script. Make sure to navigate to your default user folder. You can keep the same name or change it. Save the script by clicking OK.
[image: ]
6. Change the study region to point to the shapefile you just loaded
Navigate in the script to line 27. This line creates a new variable called studyArea. The variable is a container storing information about a Fusion Table that represents our area of interest. 
Change the information that appears after the equals sign from ee.FeatureCollection('ft:1LEGeqwlBCAlN61ie5ol24NdUDqB1MgpFR_sJNWQJ');  to CambodiaStudyRegion;, the name of Fusion Table you just imported and renamed. See image below.
[image: ]
Click Save to save your script.
Then click Run and review the impact of the changes on your map data. Do you notice a difference in the map window? 
Line 107 and 108 centers the map window on the new study area and sets the scale parameters. Change 6 to 8 or 9 to zoom in closer to the study region of interest by default.
Save and re-run your script.
Next turn on one of the Landsat Harmonics layers to display the result in the map window.   
[image: ]
Set the seasonal parameters to match the phenomenon (or land cover) of interest
The step 2 user parameters start on line 30. Here you can change the metric of interest and the number of seasons per year you would like to estimate.
Read through the list of available spectral bands and derived metrics available, starting on line 31. The list of metrics includes the (cloud, topographic, etc.) processed Landsat spectral bands, a series of normalized difference metrics, tasseled cap bands and angles, two common band ratios, and three other commonly used remote sensing metrics (EVI, SAVI, and IBI).
Select the metric of interest from the list. You will want to select a metric that you think will capture seasonal changes in your land cover of interest. Change line 40 to match the text to the metric of interest. Make sure you match the spelling exactly and enclose it in quotations marks. Or you can keep ‘ND_nir_red’—this is the normalized difference vegetation index, a measure of plant greenness.
3. On line 41 you can change the harmonics number to the number of seasonal cycles you expect to observe in a year. 1 (cycle) will estimate one green up season. 2 will estimate two cycles per year. 3 will estimate three cycles per year. Each additional cycle will add two more bands to the image. For example:
0. Setting it at 1 will result in an image with 6 bands: the constant, a linear coefficient, phase, amplitude, RMSE, and number of images. 
0. Setting it to 2 will result in an amplitude and phase band of the wave function fit to both one and two cycle waves (2 phase bands, 2 amplitude bands, plus the other four) 
0. Setting it to 4 will result in an amplitude and phase of the wave function fit to both one, two, and three cycle waves (3 phase bands, 3 amplitude bands, plus the other four). 
var dependent = 'new_metric_name';
var harmonics = 2; 
Set the year range for calculating cloud shadow statistics
3. On lines 45 and 46 you can change the start and end year for which the cloud shadow statistics are calculated. You want to make sure your year of interest is included in the range and that enough years are included to build a good distribution of images from which to determine thresholds for cloud shadows. We recommend using at least a 7 year time span. 
6. Specify the width of the date range used to calculate the seasonal trend
4. On line 50 you can adjust the number of years used to fit the seasonal trend pattern to. 1 includes two years of data: one before and one after the target. 2 would include four years of data. We suggest running it set to 1. You can increase this number later and re-export if you face persistent cloud issues.
Set coordinate reference system of the exported data set
You can modify the coordinate reference system on line 54. The coordinate reference system for the output image is specified using the EPSG code. You can look up the EPSG code for your desired spatial projections at http://spatialreference.org.
Select Landsat Collections
On line 58 you can switch between top of atmosphere or surface reflectance values that have been atmospherically corrected. We recommend using the surface reflectance, since this method attempts to remove inconsistencies in values due to haze.
On line 62 you can decided to include or exclude images collected from the Landsat 7 mission. You might want to exclude these images because they create a streaked appearance in the data output due to gaps from the scan line corrector failure.
Adjust cloud and shadow thresholds and compare changes
Starting on line 64 there are a series of parameters you can adjust to redefine your cloud masking thresholds. 
There are three cloud and cloud shadow masking algorithms to choose from in this script: fmask, cloudscoreTDOM, or a hybrid approach. Test to see which performs best in your region. For more information on these cloud and cloud masking algorithms, please see Appendix 1.
Lowering the cloud threshold, on line 72, will reduce the presence of cloudy and/or hazy pixels in the image if you use the cloudscoreTDOM or hybrid approach to mask clouds and cloud shadows. Adjust the cloudThresh variable on line 72 to obtain an optimum level of cloud masking.
You might not be able to eliminate all clouds. Some areas have such persistent cloud cover that there may not be clear imagery within your composite time period.
Read through the comments describing the other parameters you can modify. These are all described in Appendix 1 in the manual. 
For now, leave these set at their default values. However, I encourage you to test out different settings if you have time later.
Save your changes by clicking the Save icon. 
Export to Google Drive
Once you are happy with all the settings, you will export the data into your Google drive. Click Save to save any changes in the script. Then click Run one more time.
Now navigate to the Tasks tab. Here you will see there is a line with the name of the Harmonics files that have been generated for export, e.g., Harmonics_SR_ND_nir_red_2013_2015. There is one file for each year in your year interval set up to run the cloud shadow statistics. The naming convention is:
The first part of the name indicates that you are downloading a harmonics data set. 
This is followed by SR or TOA to indicate surface reflectance or top of atmosphere reflectance, respectively. 
Then the metric of interest is indicated. In the example above it is the NDVI metric, which is the normalized difference (ND) of the near infrared (nir) and red bands: ND_nir_red.
Finally the numbers at the end of the name represent the year interval of data used to fit the seasonal trend.
Locate the file with the year(s) of data that you want to export. 
[image: ]
Click on the blue RUN button. This will open a new pop up box where you will confirm the export parameters and initiate the export. 
[image: ]
Keep all default settings and click the blue RUN button one more time. This will start the export and the blue RUN button under the Tasks tab, next to the file name that you chose to download, will change into a spinning Google Earth Engine logo. Once the data is saved into your Drive folder, the spinning logo will be replaced with a check mark and a count of how long it took to export.
Note: After you start the export, you can work on something else. Once you initiate the export, it begins running on the cloud until it completes. It will still run even if you close your window (or turn off your computer). 
Download the images from your Google Drive to your desktop
Go to https://drive.google.com/drive/my-drive 
Locate your composite, right click, and select download.
If you receive a message reading “Can’t scan file for viruses” click DOWNLOAD ANYWAY. The file will download locally to the location specified in Chrome.
Repeat for Time 2
Generate a time 2 Landsat composite
Use what you have just learned in this exercise to create a second seasonal image data set, or a harmonics layer, that matches your ‘before’ year. This will be used in the change detection supervised classification process in the next exercise.
Note, because these downloads take a long time to complete, we have included the imagery on the USB flashdrive for you.

[bookmark: _Toc508631583][bookmark: _Toc508632699][bookmark: _Toc508632739]Appendix 3: Seasonal Metrics 
 We represent the seasonal signature, or phenology, as the amplitude of the seasonal difference in the normalized difference vegetation index (NDVI)—although you can calculate this on any of the Landsat or Sentinel bands and derived metrics. 
We measured amplitude using a harmonic regression time-series analysis on Landsat images recorded between 2012 to 2015. Multiple linear regression is performed on NDVI observations, assuming that there is a sine curve (a harmonic, or Fourier transform) with a frequency of one cycle per year that describes the annual variation in NDVI, Eq. 1 (Shumway and Stoffer 2006). 

[image: ]
The ’s are the coefficients, f is the frequency, and t is time. Finally, to more easily interpret the cosine and sine coefficients  and  we convert these to amplitude, , and phase, , (Eq. 2 and 3). These calculations and sampling were performed in the Google Earth Engine platform.

[bookmark: _Toc508632682]Band List
Here is a complete list of the bands in our seasonal composites. The factor is the number that band was multiplied by before being cast to signed 16 bit integer. To get the original values, divide by the factor. 
	Band Name
	Description
	Factor

	Metric name_constant	
	Constant value from the linear model
	1000

	Metric name_t
	Linear model term, a measure of longer term trends over the period of interest (e.g., gradual changes due to degradation or regrowth that occur independent of season trends)
	1000

	Metric name_phase_1 and another for each number of cycles you have selected
	The timing of the peak of the wave (e.g., timing of the peak seasonal green up), the year is represented as radians (range is – to ).
	1000

	Metric name_amplitude_1 and another for each number of cycles you have selected
	Amplitude of the variation in the metric of interest (height of the wave)
	1000

	Metric name_RMSE
	Root mean square error between the observed Landsat value (or derived metric) and the estimated values 
	1000

	Metric name_numImages
	Number of images that were used to fit the time series at each pixel location
	1



[bookmark: _Toc508631754][bookmark: _Toc508632683][bookmark: _Toc508632700][bookmark: _Toc508632740]References
For more information about time series analysis in Earth Engine, visit the material on the Google Earth Engine website: 
Slides - Video - Code Lab
Presenter: Nick Clinton
Description: This session will cover time series topics including linear modeling, auto-correlation, cross-correlation, auto-regression, smoothing and iteration.
Prerequisites: Intermediate to advanced programming with the Earth Engine API.

Shumway, R.H.; Stoffer, D.S. Time series analysis and its applications: with R examples; Springer Science and Business Media, 2006; pp. 183.
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:\Data\Images\imagery_subset>gdalinfo —hist 2008_LC.tif
river: GTiff/GeoTIFF
iles: 2088 _LC.tif
2008 _LC.tif .aux.xml
ize is 2079, 2203
oordinate System is:
[PROJCS["WGS 84 ~/ UTM zone 48N,
GEOGCS["'WGS 84",
DATUMLWGS_1984",
SPHEROIDL"WGS 84" 6
AUTHORITY [*
AUTHORITY ['EP!

137, 298 257223563,
e

PROJECTIONL"Transverse_Mercator"]1,
PARAMETER["latitude_of origin".@1.
PARAMETER[“"central_meridian",1851.
PARAMETERI[“scale_factor".8.99961.
PARAMETER["false_easting",5000001,
PRRﬁHETER["falserrt}ung“ a1,
UNIT[Vmetre"

RUTHORITY["EPSG" 988111,
AXIS[“Easting",EAST]1,
ARIS["Northing”,NORTH 1,

AUTHORITY [ EPS! * v
Origin = (538778. BIBIBIBIBI P00 . 1434960 . 0100ABABAEAANEOA>

Pixel Size = (30. BPB000 ., -30 . 0BABRBRBNEBBBREG >

Metadata:

AREA_OR_POINT=Area

Image Structure Metadata:

INTERLEAUE=BAND

Corner Coordinates:

Upper Left < 538770.000, 1434960.000> <185d21’26.96"E. 12d58’48.2
Lower Left < 538770.000, 1368870.000> <185d21’23.97"E. 12d22’56.8
Upper Right ¢ 601140.000, 1434960.000> <1@5d55°57.19VE. 12d58’43.1! >
Lower Right ¢( 601140.000. 1368870.800> <1@5d55’49.37VE. 12d22’51.91"N>
Center ¢ 569955.000, 1401915.808> (105d38’39.37"E, 12d48’50.61"N>
Band 1 Block=2B7?x%agype=Byte. ColorInterp=Gray

Min=1.000 Ma:
an=1.761, StdDev=8.946

N>
N>

etadata
STATISTICS _MAXIMUM=4
STATISTICS_MEAN=1.7611718087908
STATISTICS_MINIMUM=1
STATISTICS_STDDEU=8.94557741167893

:\Data\Images\imagery_subset>
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Change_detection\Data\Conposite\inagery_subset>gdalinfo —hist LC_88_13_NBR.til

river: GTiff/GeoTIFF
iles: LC_@8_13 _NBR.tif
LC_@8_13_NBR.tif .aux.xnl
fsize is 1036, 1571
oordinate System is:
[PROJCS ["IGS 84 ~ UTM zone 47N".
GEOGCS[ UGS 84",
DATUML™UGS_1984",
SPHEROIDL"WGS 84",6378137,298 257223563,
AUTHORITY [ VEPSG", "2030"11,
AUTHORITY ["EPSG", 632611,
PRIMEML "Greenwich”,81,
UNITI "degree",8.01745329251994331,
AUTHORITY [VEPSG”, "4326"11,
PROJECTION[ “Transuverse_Mercat:
PARAMETER
PARAMETER
PARAMETER|
PARAMETER|
PARAMETER
UNITL"netre
AUTHOM TS {/EPSG, 000111,
AUTHORITY
igin = (480124.254650000820000,934670.216683333360000>
ixel Size = (29.989977622701915,-30.008989197221517>
letadata:
AREA_OR_POINT =Arvea
Inage Structure Metadata:
INTERLEAUE=BAND
orner Coordinates:
< 4808124.255, 934878.217) ¢ 98449’ 9.96"E, 8427’ 8.62"N)
¢ 48@124.255. 886926.895) ¢ 98d49°10.66VE. 8d 1’25.44"N>
pper Right ¢ 511193.871. 934820.217) < 99d 6’ 6.10"E, 8427’ 8.72"N>
over Right ¢ 511193.871. 886926.895) < 99d 6’ 5.70"E, 8d 1’25.54"N)
enter < 495659.863, 918498.156> < 98d57’38 11"E, 8d14’13.17"N>
and 1 Block=1836x? Type=Byte, ColorInterp=Gray

Min=1.800 Max=5.000
Mean=2.967, StdDev=1.331
0.6 to 5
5539 54484 13932 7685 27140

STATISTICS MAXIMUM,

STATISTICS MEAN=2.9669332597984
STATISTICS MINIMUR

STATISTICS STDDEU=1.331192172658

Change_detection\Data\Conposite\inagery._:




image175.png
Water Forest Other Forestloss  Forestgain

‘Area 5,539 13,932 7,685 27,140
5 557108 70 e S T T

W 51% 12.8% 7.1% 24.9%

Temoror Terroror Teer
emision/100= omision/100- 08 Lerror o emission/ 100=
s 0 0.01 0.01 0.01
JOI(1—01) (01(1-.01) (B(1-8)- .01(1—.0D)-
04 0.099
S 0 0.099 0.099

@) 0.005





image176.png
fExanple

Output stratified random sample using specified allocation to a shapefile
and raster image in a randomized order and a specified seed value.

sanple_nap.py ~v ~—size 208 —-allocation "58 25 25 188"
“nask 8 —-ndv 255

I ——raster output.gtif —-vector samples.shp —-seed 10008

I stratified input_map.gtif

opy_of :
https://github.con/ceholden/mise/hloh/master/maps/sanple_map.py

\Data\Images\imagery_subset>python C:\QGIS_Scripts\sample_map.py —v —-mask @ |
size 88 —-allocation "10 10 10 10 18 10 10 1 vector change_sanple.chp strat]
ified LC @8 13 NBR.cif

DEBUGE Using map image LC_B3_13_NBR.tif

DEBUG: Sanpling method is stratified

DEBUG: Sample size is 88

DEBUG: Allocation is [10 10 10 18 10 10 18 101

DEBUG: Mask values are L8]

DEBUG: Uriting output raster to sample.gtif (GTiff)

DEBUG: Uriting output vector to change sample.shp CESRI Shapefile)

DEBUG: Read in map image to he sampled

DEBUG: Found 8 classes

DEBUG: class 1 - 944898px (20.63%)

DEBUG: class 2 - 6353px (B.14%)

DEBUG: class 898674px {19624

DEBUG: class 85043px (1.86%)

DEBUG: class 1284177px (28.047>

DEBUG: class 936713px_<20.45%>

DEBUG: class 27174px (8.59%)

DEBUG: class 8 - 397005px (8.67%>

DEBUG: Performing sanpling

DEBUG: Sampling class 1

DEBUG: collected sanples

DEBUG: Sampling class 2

DEBUG: collected sanples

DEBUG: Sampling class 3

DEBUG: collected sanples

DEBUG: Sampling class 4

DEBUG: collected sanples

DEBUG: Sampling class 5

DEBUG: collected samples

DEBUG: Sampling class 6

DEBUG: collected samples

DEBUG: Sampling class 7

DEBUG: collected samples

DEBUG: Sampling class 8

DEBUG: collected samples

DEBUG: Randonizing order of samples

DEBUG: Finished collecting samples

DEBUG: Writing raster output to sample.gtif

DEBUG: Uriting vector output to change sample.shp

DEBUG: Sampling complete

\Data\Inages\inagery_subset>
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A 5 c o 3 F G H 1 ) K L M N
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/1 9. Specify which cloud/cloud shadow masking method
/1 Choices are fmask, cloudscoreTDOM, or hybrid to run cloudScore/TDOM and then fmask
var cloudcloudShadoullaskinghethod = *cloudScoreToO!" 5

/7 10. Choose whether to include Landat 7
/1 Generally only included when data are limited
var includeSLCOFFLY = false;

/7 1. metadataclowdCovertinx: Cloud cover percentage in inage metadsta threshold.
77 Vi1l not include insges with cloud cover > this mumber. Set to 100 if

77 using metadata cloud cover is not wanted

Var metadataCloudCovertiax = 50;

/7 12. Cloud and cloud shadow masking parameters.
/1 cloudThresh: If using the cloudScoreTDOShift method-Threshold for cloud
/1 masking (louer number masks more clouds. Betueen 10 and 36 generally
/1 works best)

var cloudThresh = 20;

/1 25coreThresh: Threshold for cloud shadow masking- lower number masks out
/I less. Betueen -0.3 and -1.2 generally works uell
var zScoreThresh = -

/1 shadowsunThresh: Sum of IR bands to include as shadows within TDOM and the
/1 shadou shift method (lower number masks out less)
var shadouSunThresh = 0.35;

/1 contractpixels: The radius of the number of pixels to contract (negative buffer)
/1 clouds and cloud shadows by. Intended to eliminate smaller cloud patches

/1 that are likely errors

/1 (1.5 results in 3 -1 pixel buffer)(0.5 results in a -0 pixel buffer)

/7 (1.5 or 2.5 generally is sufficient)

var contractpixels = 1.5;

/7 dilatepixels: The radius of the number of pixels to dilate (buffer) clouds and cloud
/I shadous by. Intended to include edges of clouds/cloud shadows that are often missed
/7 (1.5 results in a 1 pixel buffer)(.5 results in a © pixel buffer)

/7 (2.5 or 3.5 generally is sufficient)

var dilatepixels = 3.5;

// 13. If using surface reflectance data, haze can be removed
var removeHaze = false;

/1 1f removing haze, choose threshold. Generally 200-300 works well. Higher number
/7 will mask out less

var hazeThresh = 2003
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5. The script is very simple — it loads the tree cover, loss and gain image into the window display.
Forest appears as green, forest loss as red, and forest gain in blue.

‘Note: if you'd like to learn more about Hansen's Forest Data Products and methods, you can find his
publication in the Flash Drive under the resources folder.

You can explore additional Google Earth Engine scripting exercises here.
https://developers.qoogle.com/earth-engine/tutorial_hansen 01

6. Z0om in and scroll around the region — where do you see changes occurring over time? How
accurate do you think this data set is for depicting changes within your study region?
[ you'll notice that the same pixel can be classified as loss and gain.

T

You can also visit the University of Maryland Global Forest Change website, which uses Google Earth
Engine to display just the areas of forest loss since 2000. These areas are color coded by the year
deforestation occurred.

8. Open this link in your web browser: http:
global-forest
i. Zoom into the study region (near Phuket in southern Thailand, see image below).
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1. If you have Google Earthinstalled on your laptop, navigate to the km file stored here:
K C:\Change_detection\Data\shapefiles\Data_Exploration
2. Double-click the file called Change_Examples.kmz.
3. This will open up the file of these same areas in Google Earth. You can now explore the
changes in land cover using the imagery in Google Earth.
i.slide the button along the timeline slider (in the upper left hand corner of Google Earth) to
B view the imagery going back and forward in time.
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1. When testing new algorithms or forms of analysis, computationally it makes sense tostart
with  subset. This makes it faster to repeat the analysis with different parameters or options.
With your rasterimage open in QGIS, g0 to Raster » Extraction > Clipper.

For the Input file choose your Landsat image.

Save the Output file to “1_Introduction/4_subset”.

For Clipping, mode choose “Extent””

Now draw on the raster layer the extent you want to subset. If you click and drag with the
mouse it will automatically draw a bounding box. Size does ot particularly matter, but try to
make it big enough to capture multiple land covers. Alternatively, if you have coordinates you v
wish to use you can enter them in the boxes provided. If not, they will automatically be filled
in by the bounding box you draw.
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1.4.4 Forest definition

A forest definition is needed to be able to determine whether deforestation or afforestation or
reforestation has taken place, and to define the areas within which degradation and the
other REDD+ actvities may ocour.

The IPCC 2003 GPG defines Forest Land as including all land with woody vegetation
consistent with thresholds used to define forest land in the national GHG inventory, sub-
divided into managed and unmanaged, and also by ecosystem type as specified in the IPCC
Guidelines. It also includes systems with vegetation that currently fall below, but are
expected to exceed, the threshold of the forest land category. The Forest Land definition in
the 2006GL refers to threshold values. IPCC therefore anticipates that countries will have a
forest definition with quantitative thresholds.

No single definition has been agreed under the UNFCCC for REDD+ purposes. Countries
will often have an existing forest definition in place, and the COP has decided that, as part of
the guidelines for submission of information on forest reference levels, Parties should
provide the definition of forest used, and if there is a difference with the definition of forest
used in the national greenhouse gas inventory or in reporting to other international
organizations, an explanation of why and how the definition used in the construction of forest
reference emission levels and/or forest reference levels was chosen™.

Countries that do not already have a forest definition may wish to note that for Kyoto
Protocol (KP) purposes Forest ...is a minimum area of land of 0.05-1.0 hectare with tree
crown cover (or equivalent stocking level) of more than 10-30 per cent with trees with the
Ppotential to reach a minimum height of 2-5 metres at maturity. A forest may consist either of
closed forest formations where trees of various storeys and undergrowth cover a high
proportion of the ground or open forest. Young natural stands and all plantations which have
yet to reach a crown density of 10-30 per cent or tree height of 2-5 metres are included
under forest, as are areas normally forming part of the forest area which are temporarily
unstocked as a result of human intervention such as harvesting or natural causes but which
are expected to revert to forest™.

In developing an NFMS, countries will need to establish whether there is an existing forest
definition, and if not to put one in place. Definitions can differ in ecosystem coverage, which
can have a significant effect on the estimate of emissions or removals associated with
REDD+ activities, and the allocation to activity (Box 2). Definitions should therefore be used
consistently over time, and the definition used o establish the FRL or FREL should be the
same as that used for subsequently for MRV.

 See the Annex to decision 12/CP.17, Guidelines for submissions of information on reference levels.

*'In the Forest Resource Assessment 2010 FAO defines Forest as Land spanning more than 0.5 hectares with
trees higher than 5 melers and a canopy cover of more than 10 percent, o trees able to reach these
thresholds in situ. It does not include land that s predominantly under agricultural or rban land use. The area
threshold fals within the range in the KP definiion and the height threshold is at the upper end of the KP.
range.

2 GFOI Methods and Guidance
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